Replies

          • Developer

            Hi Ahmed,

            Do you have the logs of that successful flight?

            One thing to understand that may help you with the setup is that when you enable ELEVON_OUTPUT that is exactly the same as installing a hardware elevon mixer in your plane on the elevator/aileron channels. So all of the flight control algorithms, stability etc is the same on a flying wing as any other plane.

            Cheers, Tridge

            • Hi Tridgell / Gary

              If motor stops and plane is in auto mode loitering over head will it decent in glide mode or try to give elevator to maintain altitude . As in my last flight it nose dived after motor stops on low voltage.

            • Hi Tridge

              attach pl find the log of successful flight.

              Ahmed

              2014-10-02 13-36-48.tlog

  • Attached find log file

    2014-10-11 15-43-32.tlog

    • Developer

      Hi Ahmed,

      Looking at your log it is clear your RC calibration is a long way off. When you are flying in manual the zero of your sticks is around 1600 for channel 2 and 1447 for channel 1. Those values need to be in RC2_TRIM and RC1_TRIM so that ardupilot knows when you want the plane to fly level. It also looks like your _MIN and _MAX values are wrong. So start by re-doing your RC calibration. I suspect you may have skipped that step. You may also like to read up on the TRIM_AUTO option (make sure you read the docs carefully to understand how it works).

      You should also fly in FBWA or AUTOTUNE before any other mode. Your flight log shows most of the flight is manual, then you skip straight to auto. You do spend a couple of seconds in RTL and FBWB, but not enough to actually tell how it flies.

      I'd also highly recommend you read up on AUTOTUNE mode. If you are already comfortable flying the plane in manual then try AUTOTUNE_LEVEL=7.

      Cheers, Tridge

      • I think  you are right trim seems to bit out i will enable auto trim and will test the result also will recalibrate the radio.

      • I will re calibrate and will check the result 

      • Tridge, when I upgrade to 3.1.1 on my flying wing, do I need to re-do the accelerometer calibration? Thanks Jeff

  • Moderator

    Usually a setup problem, many are using AP3.1.1 quite happily on a flying wing. Test on the ground with the aircraft level, If you switch to FBW_A (don't use FBW_B just yet) then the elevons should stay level and move in their correct directions when the aircraft is rolled or pitched. If not your setup is wrong.

    • It is not a problem for configuration what I think it is not taking the altitude it seems it is trying to go to altitude below 200M were as I have kept the default altitude 200M and I also tried to give higher altitude but same behaviour what I assume the Eprom is not flashing write value and in one flight it worked ok also.
This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
More…