Arduplane problem, plane ran away doing spirals

Hi,

 

After about a month of playing with the mission planner and xplane, i finally mounted the ardupilot mega with 2.24 software on a powered glider (asw 28). The plane has lots of power (almost 2x thrust to weight ratio) and is very stable.

 

The day started with a first flight with the STABILIZE and RTL modes set up on the flaps switch. STABILIZE worked very well and after a minute of playing around i switched it to RTL, which also returned the plane over my head at the proper altitude; 80 meters above ground, which was also at 80m, so about 160m above sea level. Due to the wind (4-6 knots), it was doing ovals instead of perfect circles, but it definitely loitered above home without problems in RTL mode.

 

After recharging the battery, i set up a simple 3 waypoint mission, in a triangle shape around the launch point. Took off into the wind and also towards the first waypoint, i turned left so i can see if it goes right when switching to AUTO.

It went to the first waypoint and then instead of going to the second it went somewhere in between the second and third, and kept going. At that point i switched it to MANUAL for a second and then thought i would try RTL to bring it back. It did turn it around but instead of coming home it went right, and kept going.

Because it was overcast and hazy i lost it quickly. When i saw it again i tried MANUAL, but lost it very quickly and then switched it back to RTL and AUTO hoping it would come back home. Jumped in a friend's car to follow it, but we were too slow and never saw it again. After moving between AUTO and RTL a few times i put in in MANUAL and as you can see in Google Earth that's what brought it down.

 

It took us a few hours to find it, as you can see it's about 1500 meters away from the launch site, in the middle of a field.

 

The wind direction is marked with the big red arrow in the kmz, so i don't think the wind took it away since it went crosswind and even a little upwind while doing the spirals. The launch site is marked with the smaller blue arrow.

 

One thing i noticed that maybe affected things is that the compass wasn't enabled in Settings, but then again it wasn't enabled 30 minutes before either, when RTL brought the plane back home perfectly.

 

I've attached a zip with the original log, a cut down version of it without the long start and very long end (when it sat there crashed waiting for us). One thing to note is that the original log containts an error i don't understand somewhere at the beginning.

 

The plane's setup is also included.

 

I would really appreciate a bit of help, i'm completely stumped.

ardupilot_problem.jpg

Ardupilot Problem.zip

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had a similar yet unrelated issue one flight... For some reason in the middle of the flight Ardupilot switched from AUTO to FBW mode and took off flying large circles away from me. (I guess because it kept the roll that it started FWB mode in?) .

     

    The odd thing is that it was setup to switch to AUTO mode when it was out of range of the transmitter, and I tested this several times in the past and it always worked (in fact I would often fly with the transmitter turned off to save the batteries), but after about 500m (over a hill) it was out of range enough to not respond to mode switches, yet it was still stuck in FBW mode. I tried to run after it to get back in range, but in hindsight this was stupid, as I should have ran to my laptop and manually switched it to AUTO mode through the Xbee which has much greater range than my transmitter. 

     

    Anyways, I set my transmitter to AUTO mode and jumped in my car to chase after it, almost 2km later either Ardupilot came to its senses or I finally got within range and my transmitter got it back into AUTO mode itself, but the plane started heading back home, thankfully... I was *really* lucky, especially after examining the logs after, as it came within about 20 feet of crashing straight into a low mountain top, an updraft was likely my savior on that one.

     

    One lesson I learned from this is try to avoid putting a plane "gone wild" in MANUAL mode if its flying away from you and is already almost out of sight, as its sure to crash. At least in any other mode Ardupilot is more likely to keep it level/flying giving you enough time to catch up to it. If not a gradual descent when the battery dies is better than a spin/dive into the ground with no one at the controls. 

  • Hello,

    I've a similar problem. I've noticed that my plane don't stay in manual mode!

    I switche to manual but my plane switches to an other auto mode. ( on ground , manual mode on)

    I'm using arduplane since one year and it's the first time I notice that (2.24).

    An other problem is that I haven't any logs to download... :( (yes I did some reset before..)

  • 3D Robotics

    That looks like you're using a non-standard airframe and the Nav isn't tuned well enough to fight wind. If you're not using one of the recommended platforms, you need to tune the PIDs for your plane as shown in the manual here. In particular, it looks like you need to crank up SERVO_ROLL_P

This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
yesterday
More…