Arming the hexa motors ....

Hi guys,

I have resolved the RC problems. It was a defect receiver in fact, and after changing to a new one, the binding process worked fine, as well as the radio controls calibration. 

Now the next step : calibrating and arming the ESC's. I think the calibrating worked, as I heard a lot of different bleeps and melodies, but as I bring the throttle back down after a few minutes, I have no response of the motors to the throttle. Also after unplugging the lipo and repowering, I tried to arm (throttle to the right bottom for 3 seconds ...) but no response .....

What's wrong now ?

I had the switch in fly mode, I suppose that's OK ? The blue LED on the board is blinking slowly.

Filip

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi,
    Thanks a lot to Gareth ! I followed your advice to the letter and I managed to calibrate all my ESC's, I think. Although they didn't all react in the same way. Two of the six actually responded immediately to the full throttle when I plugged them in my receiver. After the calibration, the arming was also kind of funny. No direct reaction to the arming with the throttle stick to the far right bottom for a couple of seconds. So I changed the switch to the CLI mode (I think) or the closest to the RX pins. I still didn't get any arming with stick to the right. But when I moved it to the left for a second or two, I got to arm them, strange no ? So, there must be a couple of details to be corrected here, but I'm already very happy to see my motors turn at last !!!! Thanks to all those that helped me out so far....
  • I have admit that the original JrDrones videos on this were what allowed me to first figure this out.

  • Let us address the ESC calibration. Leave the transmitter on with full throttle. and the esc you want calibrated plugged into your throttle channel. Plug in the ESC. You will hear a few beeps, I cant remember 3 or 4 maybe. Then immediately reduce throttle to 0%. You will hear a confirmation beep/s. Then unplug the esc from the lipo, then plug it back in. After the esc has booted you should have full control over it using your throttle. Calibrating the escs takes less than 20 seconds, its the unplugging and plugging and losing count ETC that make it a pain. I will share a "lazy secret". Instead of unplugging the 3pin connector from the PDB on the arducopter, Use a small jump wire (1 end female sil, other end male sil) and plug the receiver into the 4 pin sil motor connector that gets plugged into the APM. Works for me :)

    Not being able to arm can be un calibrated escs or perhaps a reversed channel on your transmitter or APM planner.

    Calibrate the ESCs, if that doesnt fix the problem. Check in APM planner that you have the correct stuff mapped to the correct places, as well as going in the correct directions. If you move the stick to the right, the green bar should move to the right.

    Wash, rinse, repeat ;)

    If you dont come right with the esc calibration, let me know and ill post a video of the process :)

    G:)

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race is next Saturday. Compete from home using the @donkey_car simulator -- no physical ca…
1 hour ago
DIY Robocars via Twitter
RT @RoboticMasters: Students from @Sydney_Uni working hard on improvements and changes to @donkey_car simulator. @diyrobocars @adafruit…
1 hour ago
DIY Robocars via Twitter
Practice virtual race this Saturday; the real thing will be on Oct 3 https://www.meetup.com/DIYRobocars/
Wednesday
DIY Robocars via Twitter
Wednesday
Derrick Davies liked lisa TDrones's profile
Wednesday
DIY Robocars via Twitter
Sep 21
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
More…