Auto Analysis error message in Mission Planner

I have been using Mission Planner for 2-3 years without problem. Recently, after downloading data flash log via Mavlink  and reviewing the log, I clicked the Auto Analysis button m and got the following error message :--

                            The type initializer for "NumpyDotNet.NpyCoreApi" threw an axception

After I clicked OK, got another message saying :"Bad input file".

  MP version  1.3.35

This happens on Arducopter 3.2.1,  Arduplane 3.2.3, on both my desktop and laptop, and on both APM2.6 and Pixhawk.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I've just started having problems with Auto Analysis , I am using MP v1.3.39, Arduplane 3.6
    I have only recently started using plane, but I've used arducopter for 2 years without problem.
    MP does load an older log from plane 3.4 but my latest logs from 3.6 I get "bad input file".
    I initially wondered if my log file was corrupted but I've loaded them ok in "review a log"
    And the kmz file loaded also.
  • Developer

    plase update to the latest MP.

    • @Michael,

      thank you for your excellent Mission Planner, excellent tool for  Drone Crash Investigators with FAA

      BTW1

      I exactly got the same error, so Auto Analysis is down for me.

      Maybe the case is log file from one build is not fit to open for another build.

      BTW2

      How to set ranges to fit selected charts ?

      Sometimes, selected charts are out of group range (left and range ranges)

      I recall screenshot of MP charts supporting multi-column ranges to the left, each featuring color to match charted data.

      Only yesterday I studied drone crash and GPS.Alt and Bar.Alt charts didn't match the preset range.

      I was told GPS.Alt was all above 1,000 m and Bar.Alt was up to 10 m in altitude.

      Sometimes I get GPS.Alt.Rel to match Bar.Alt data range.

      BTW3

      Yesterday I played log file from another drone crash and got no GPS.Alt refresh

      in Google Maps window.

      GPS.Alt got updated clicking Play/Stop Play/Stop Play/Stop

      Ok, old 2GHz PC, and disk is almost full, Windows XP.

      BTW4

      Any chance for MP manual as a single file ( Word, PDF format) ?

      If I live on off-line PC, I don't have an opportunity to read manual on-line or click wiki every time.

      My congratulations.

      Excellent job, excellent MP, you should be honored by Secretary Foxx, FAA, White House, NSA, DARPHA, for what you did for the individual drone hobbyists to let them fly safely

      and study every drone incident like a Profi.

      Be my friend.

      darius

      • Developer

        Hi,

        I will answer based on your numbers above

        1. there was an issue with the older version of MP, with a dll error about numpy, it is now fixed.

        2. with graphs depending on how you select them they can be graphed on different axis. ie left click on, vs right click. in the dataflash log viewer you can add data modifiers to bring data inline, do this by double clicking the entry in the tree view

        3. was the problem there on other pc's as well. (just trying to find out if it was because it was a slow pc, or if it is a bug)

        4. currently there is not. although with the recent changes the wiki is being moved to GitHub, so there maybe some changes in the area.

        Thanks

        Michael

        • Michael, I am also having issues with Auto Analysis:

          MP ver 1.3.37 bld 1.1.5917.13431

          Pixhawk: APMCopter V3.3.3 (acf2e10c)

          MP running on windows 7 environment 

          Downloaded logs, select "Auto Analysis" and navigate to folder where my log files are stored I get the following error:  "Error   Could not add reference to assembly mtrand.dll".  After receiving this error message I select OK, and I get the message "Bad input file".  Does not matter if I select log or .bin (bin is converted to log without an indicated error).

          2016-04-18 09-25-16.bin

          https://storage.ning.com/topology/rest/1.0/file/get/3702813477?profile=original
          • Hi Michael

            I have been using Mission Planner for more than 3 years Its a great GC it does everything we need from set up analysis to mission planning but i notice on the latest release the abasulute function has been removed how do i get it back i notice if i place a way point with verify height on it will place the first way point at the default altitude then the next one is placed ASL which is what i need

            Thanks in advance and hope i am not asking this in the wrong place Sorry i sorted it out if you verify alt first it works

    • Thanks for reply.

      MP 1.3.35 build 1.1.5878.12941 which I am using is the latest version, I believe, as I checked for update in the HELP section of MP, and it came back saying there is no update.

      Any other clue that you can suggest ?

      Thank you.

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…