Auto mode nosediving/note following waypoints

After verifying that FBWA works great on my Skywalker, we were trying out auto mode. We tried with two flight plans, one with a takeoff waypoint and one with 3 nav waypoints, and then one with 3 nav waypoints. The altitude was set to 60m. We have NOT verified that RTL works.

I moved out of auto into FBWA two times when it didn't immediately start rising to 60 m. The third time, it headed to the correct waypoint (no takeoff command) and then nosedived from about 20m.

I'm attaching my last log from today's flights due to size constraints.

It is my understanding that after finishing the waypoints, the airframe should enter circle or loiter mode at a set altitude. 

Update: After reviewing the logs, the last one shows we took off in circle, then switched from manual to stabilize to manual. The telemetry screen has been displaying manual, FBW and auto as our flight modes so I don't know what's going on here. Obviously this discrepancy is the reason for our crash. I will verify flight modes tomorrow. I haven't been able to update Mission Planner on our laptop - it freezes during the "updating parameters" step.

97.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Update: user error. Because flight mode 6 is set to manual, when I thought I was switching to auto, it was actually passing auto and switching to manual.

This reply was deleted.

Activity

Derrick Davies liked lisa TDrones's profile
Wednesday
xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…