Bad AHRS - Pixhawk

Pixhawk, Arduplane 3.2.2.

Hello guys,

having a problem to make EKF to work. 
As soon as I put the EKF_ENABLE 1, the massage "BAD AHRS" appears on my Mission Planner screen. I couldn't find any similar topic on other forums so you're my last chance =)

I thought that it's might be a hardware problem, but both of my Pixhawks acts the same. The IMU pin legs connections on PCB are also look fine. All the initial calibration were made.

I also had an idea that it might be a wrong EKF_ or AHRS_ parameters problem, but I varied them without any successful result. 

Both IMU seems to work according to log file. But most of EKF'1-4' logs shows zeros. Since it was recorded indoor so I turned off the "AHRS_GPS_USE 0", but even with its on and outdoor the result is the same - "Bad AHRS"

I also noticed that INS_PRODUCT_ID turns to "0", saying that IMU is unknown, but not 5 as it should be for Pixhawk.

Please help, I spent the 2 days solving this problem without any results!

Here are the Parameters and Logs.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I have this same Bad AHRS in plane 3.7.1 MP 1.3.43.

    Done all the stuff suggested. Recalibrade, power down/up, etc.  Only time it doesnt happen is when I take the plane outside.

    Any updates from anyone else?

  • Airplane 3.6.0 has solved this problem. For me it has totally gone away.

  • I am also on 3.3 plane and having the same problem with "Bad AHRS"  None of the solutions here seem to work for me.  Has anyone else solved this on plane? or just copter?

  • I also am getting more BAD AHRS errors than normal. There are probably some parameters I can change to desensitize the error message. I have looked but not sure what to tune. Does anyone know what to adjust to make this error message less sensitive?

    It does clear after I fly for a while but I am unconvertible sending it off on a waypoint mission with a BAD AHRS error showing. It seams to have gotten worse with the last airplane firmware version.




  • 100KM

    Turns out the problem is not really a problem.

    It only manifests if you have a very low quality 3d fix. As far as I understand, because of the bad fix, the EKF is having a hard time reconciling the barometer altitude and gps altitude, as well as the compass heading and the GPS heading.

    Take the plane outside and all is well. I should make a note on the github for the wiki to mention this under the AHRS error FAQ.

    • I'm having the same problem, and it's driving me insane. If I move the body of the plane, as an addition I also get ERROR VELOCITY VARIANCE and ERROR POSS HORIZON VARIANCE.

      Using Arduplane V 3.5.0 (379ca5ac)

      Someone please help. This is my third day trying to fix this. I'm NOT a programmer so please give a basic answer. I'm hoping there is a parameter in Mission planner that I can look for and change a setting.

      • 100KM

        Take your plane outside and wait for a good hdop and the error will probably disappear. Let us know!

        • Thank you, I will do that. It's raining heavily at the moment and not expected to clear for 24 hours but I will get back to you.

  • 100KM

    Nope, 3.5 doesn't fix the problem.

    I've been through 4 pixhawks and 3 GPS units, they all show the same issue. Recalibration doesn't help permanently, either.

    The problem only manifests once the GPS has a 3D fix. I've been going around in circles because of this - no I know how to test properly.

    Along with the AHRS error, one can see the artificial horizon moving slightly, even if the plane is stationary.

    Why are we the only seeing the problem? I'm quite stumped...

  • Looks like 3.5.0 beta has all the fixes. Has anyone had any problems with the new firmware?


This reply was deleted.