Hello, I have been frequently flown with APM board 2.5.2 so far without major problems until recently updated to the latest firmware. 

After updating, I see "BAD GYRO" message appeared on the HUD and the attitude become upside down. 

I investigated the issue and found many people already experiencing this kind of issue and numerous report pointed about faulty regulator. When measured the 3.3V rail I get 4.5~4.7V on the line. 

So I tried to replace the regulator with MCP1700 which is about the size of the original TPS79133DBVR regulator as shown in the following picture.

Next I tried to isolate the 3.3V rail with the output of the MCP1700 to see if the regulator is actually causing the voltage problem. Interestingly enough, the output gives about 3.3V with lots of jitter and the isolated 3.3V rail shows 0.7V flowing through the entire line!

Then I close the 3.3V rail with the output of the MCP1700, the rail becomes about 3.3V and settled. No jittering, no noise but strict 3.3V output.

 

However If I power up the board with the MCP1700 output connected to the 3.3V rail, the line become 4.5V again!

So I suspect something is triggering the 3.3V output when booting the system and see what is going on the 3.3V rail when starting up.

The next picture is what I found. When the board powered up, 3.3V looks ok but exactly 1 second later, the rail becomes 4.5V and fluctuate. 

So my next question is what exactly happening at 1 second after the boot. 

Is there anybody can answer my question?

Thanks in advance.

3691176621?profile=original

scope.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • For what it's worth, I've seen this too.

    I too isolated the 3v3regulator (I think after replacing it), and discovered that some other component were to blame, I am not sure but I think the last thing I did was to desolder the I2C level converter, which proved not to be the cause.

    See attached picture from the servicelog. I think that's how I decided that the magnetometer was most likely to blame (suspiciously hot) - but never verified this theory, because after some soldering/desoldering I decided that this APM would never be used for commercial operations anyway, and later upgraded to Pixhawks everywhere.

    magnetometer error.png

    • Thanks Andre for your reply. I should check the barometer as well. Its good to know atleast someone have discovered this issue.

      Kyu
      • Hi, today I were getting an DF13-6 from this beforementioned APM,  my 3v3 were at 4.8v ,  I remembered this topic and removed magnetometer, voltage is now fine. 

        So yes, the magnetometer was to blame, as I suspected due to the attached picture.

        I am pretty sure your is too.

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…