Hi all,

        Is it not good idea anymore to run SITL on windows 7 platform (with cygwin interface plus pyserial and other add ons) ? As I see dev.arupilot.com has removed the previous SITL tutorial, which was showing instruction to run the SITL on windows 7 platform. Instead, now they are suggesting to run ubuntu inside windows with VMWare and then perform SITL ( Latest Tutorial). I couldn't understand reason behind it very well. 

       Please tell me , is it reccomended to run SITL with all LINUX platform or I can still do it on Windows ?. Or should I run Qground control with XPlane ?

       Also curretly I am following this tutorial from old website (Old Tutorial) and I am stuck at a step where we make 

$ cd ArduPlane
$ make sitl


I am getting the "C:/GIT/ardupilot/mk/environ.mk:44: *** ERROR: cannot determine sketchbook location - please specify on the commandline with SKETCHBOOK=<path>. Stop." And I couldn't figure to set a path for sketchbook, though I tried setting up the path used in Arduplane IDE.

       

Views: 1239

Reply to This

Replies to This Discussion

I'm getting the same sketchbook error, except it happens no matter what I try and make. Anybody got an idea?

Hi Nizobe,

I couldn't solve that but I stopped using that tutorial. Instead I started using the newer tutorial released by them ( http://dev.ardupilot.com/wiki/setting-up-sitl-on-windows/#Setting_u... ). I was able to perform the simulations successfully. 

Which tutorial are you following ? 

Hi Anand,

I'm following the guides from this page http://dev.ardupilot.com/ . From the section "Getting Started With the Code" from the beginning up til Editing with Eclipse. And then I tried the EZ walkthroughs as well. No luck :/

I'm trying to modify the actual firmware for custom use so SITL is a bit down the road for me.

Hi Nizobe,

Sorry It skipped out of mind to reply earlier.

Are you trying to setup the the SITL or something else ?

No, just the code itself off GitHub. I discovered the issue was a path to my repos that had spaces in it. This didn't play nice at build time. I solved it by moving my repos elsewhere on my local machine. Thanks anyway!

A year later... I just hit the same issue and removing the spaces from the directory name fixed it. Thanks for the hint!

Hi I've added the line to .bashrc as specified in the new page at http://dev.ardupilot.com/wiki/sitl-native-on-windows/

Now when I cd in ardupilot/ArduCopter and then try running

make sitl -j4, I'm getting the same SKETCHBOOK not found error.

I cloned it off GitHub and have followed the instructions so far as given. I also didn't understand where to check for space in the directories as I didn't find any.

I have no idea what to do and any help is appreciated.

Thanks!

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service