Hello there)

I've recently changed firmware v2.8 to 3.1.2, calibrated radio and accelerometer, and APM is not arming anymore. I also change ESC's to HK's Simonk, but everything else, including radio and its settings stay same. Red flashes withsingle interval and nothing changes wit stick down-right.

The board probably has crappy compass(it sends no data when enabled) but I've disabled it and this had no effect on arming APM with previous firmware.

I also know that some sort of bad TX shamanism has been required to arm early APM versions. Unfortunately, I can't remember it, and in addition to main question would be thankful if someone helped me to recall.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Glad that you've solved the problem. I have ran into similar problem (Arducopter 3.0.1)

    My problem solved when I execute the last troubleshooting step in the wiki at https://code.google.com/p/arducopter/wiki/AC2_Troubleshooting#I_can...

    11. If all that doesn't work, you may be stuck in a "calibration loop" (a failed calibration left the calibration flag set in the APM EEPROM). Go into the CLI (MP Terminal Tab) and do a Setup/Erase (this will clear your EEPROM) and then reload your ArduCopter firmware via the MP and try the RC calibration again.

  • I recommend checking the advanced parameters, compass mott offsets and making sure none of them have non-numerical "nan" values in there.  I had the same problem after I udpated firmware and ran compassmot, somehow it messed up and put a couple of "nan" in the compasmott offset parameters that should be numerical numbers.   With the "nans" in there it caused my compass and horizon to drift erratically and I was unable to arm. 

    Edit: this was with a pixhawk though so not sure if it would apply to an APM, but its a quick thing to check. 

  • Same here I updated firmware from 3.01 to 3.1.2 and my failsafe throttle value was blocking my arming. Reverted back to 3.01 and its arms fine. There must be a bug in 3.1.2 for some 2.5apm boards. 

    • Thanks for that info Michael.  How do I revert back to 3.01?

      • In your Mission Planner, Initial Setup tab, then select install firmware, All the aircrafts will show on screen, look on the bottom right you can pick previous firmware.

        • MP cannot load previous firmware list. I don't know if this happen because firmware generator site is not working, or there's a MP bug. So one can go directly to http://firmware.diydrones.com/Copter/ , download appropriate .hex and open it in MissionPlanner.

  • Now arming ok on 3.1.2 too, after reflashing back again. Still don't know what has this been. Maybe the wrong flight mode? I believe I checked it at the first time...

    • Im having the same problem.  Cant arm with the new software.  What did you do to resolve

      • Just reflashed. Than checked current flight mode and disabled pre-arm check.

        • I had a problem arming and what I found was the rtl switch was on and when I tuned it off it still would not arm. I had to switch from stabilize to alt hold and back to stabilize.
This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…