Cannot install 3.2, installation fails while reading hex

I have never been able to flash new firmware. Now that 3.2 is out I really want the new position hold mode. When I go to install firmware in mission planner I select 3.2. It goes through detecting board version, then reading hex. The bar starts to fill up and goes till about under the 75% point, then it stops and flashes up an error box "communication error- no connection". My cable and everything is fine. I have been using the same cable to monitor telemetry and program my apm for months without issue. What should I do?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • How are you powering the board? I have had problems with a laptop not supplying enough power through the USB port. Also just for the upgrade try unplugging things from the board and retrying.

    Russ

    • I have tried to update both from my mac laptop and from my desktop pc. The board has been plugged directly into both. I have in the past tried with nothing connected to the board and also tried with the board powered by the flight battery. All with the same failures. 

      • What is the baud rate on the COM port that you're using?  Also, you aren't connecting with the COM port, right?  You're just selecting it and then going through the firmware upgrade process.

        What happens when you attempt to use another COM port on your PC?  Does it actually change in the drop down list?

        -Mike

        • 115200. No im selecting the com port but not hitting connect. Then trying to update the firmware. It won't even work if youre connected it just says you cannot update firmware while connected to mavlink.  

          Yes changing the com port changes it in the drop down, but doesn't seem to help anything.

  • I found a solution after reading another forum. I disabeled the other serial interfaces in the device manager then uploaded the ac3.2. Hope this will help you as well.

    • What exactly did you disable? I had three com ports listed. One said arduino. I deleted the other two, but still no success. 

      • I disabeled all ports but the one saying arduino. 

        • I have done the same. But unfortunately that doesn't seem to fix the problem for me. 

  • I just now experience the same problem. Never seen it before. 

This reply was deleted.

Activity

DIY Drones via Twitter
RT @chr1sa: After more than a year of only virtual races, @DIYRobocars returns to the newly renovated @circuitlaunch on May 22 for the resu…
22 hours ago
DIY Robocars via Twitter
RT @DAVGtech: And now available with LiDAR 🔥 https://twitter.com/Heavy02011/status/1381137016381964293
22 hours ago
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #9 - #ParkingLotNerds #thunderhillracetrack, CA Join us for the next race April 24th,…
22 hours ago
DIY Robocars via Twitter
RT @DWalmroth: Weather's finally cooperating, looking forward to racing 1:10 scale autonomous cars outdoors again! @diyrobocars, @NVIDIAEm…
Wednesday
DIY Robocars via Twitter
RT @AIDRI_: I finally succeeded in optimizing the trajectory and speed of a car on a #racetrack. Next step: implement a 2d controller and…
Wednesday
DIY Robocars via Twitter
@jetdillo @circuitlaunch Actually the second *in person* event in a year. We do virtual races every month
Apr 2
DIY Robocars via Twitter
Update: we're moving it back one day to Sunday (the 4th) at 11:00am instead
Apr 2
DIY Robocars via Twitter
@GrantEMoe @circuitlaunch Update: we're doing it on Sunday (4th) at 11:00am instead
Apr 2
Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
DIY Robocars via Twitter
RT @chr1sa: Maybe we should have a mini @DIYRobocars race in our lower school's playground https://t.co/xLFeua1R6X
Mar 29
DIY Robocars via Twitter
If anybody wants to join us for an informal outdoors hack/race we're going to be meeting at the @CircuitLaunch park… https://twitter.com/i/web/status/1375907409223249923
Mar 27
DIY Robocars via Twitter
RT @SmallpixelCar: Ready to reopen, innovation has to continue. Inside/outside, LiDAR/GPS, race/delivery https://t.co/jpmvttoHEd
Mar 26
DIY Drones via Twitter
RT @DAVGtech: By far best race yet! Congratulations to the winner @Heavy02011 🥇🏆🍾👏👏👏 @diyrobocars @donkey_car @NVIDIAEmbedded https://t.co/…
Mar 20
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #8 - #ParkingLotNerds ⁦@DAVGtech⁩ ⁦@DWalmroth⁩ ⁦@OttawaAVGroup⁩ - join us tomorrow h…
Mar 20
DIY Drones via Twitter
RT @mrpollo: 11 years ago, the pxIMU was announced to the world on @DIYDrones, and it changed the life of many (mine included). The followi…
Mar 18
DIY Drones via Twitter
RT @ishcahealth: This is awesome! ☘️ @DroneDJ @DIYDrones @WorkerDrones @DroneMedia_UK @dublinaviation https://twitter.com/media_ireland/status/1372077878536462336
Mar 18
More…