Cannot load firmware in pixhawk

Hello everyone!

I've been having problems in loading firmware to pixhawk. I've used apm planner 2.0 as instructed. Pixhawk is connected to the computer via usb connector with peripherals connected to pixhawk which includes GPS with magnetometer, switch, buzzer and telemetry.Everytime I start loading firmware, it instructs me to unplug the pixhawk and plug it again afterwards. Status message will then be "downloading" then, "attempting to find com port" and stops. I checked again the pixhawk port in  the device manager and still it is present.

Can somebody tell me what to do please? or is the lacking of peripherals affect it as well? I hope somebody could help and could give a comment. Your comments will be very much appreciated and is a great help for me for sure. 

Thanks in advance,

Cherry

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Cherry,

    How's your Pixhawk so far?

    • Hello Jay,

      For now,  I'm still having problems in terms of arming. The peripherals connected were GPS, compass, buzzer, and the safety switch. I still can't do the Radio Calibration since I have problems on the connectors/wires. Have you tried arming it without calibrating? I can't, I just want to ask if you've tried it successfully or not, because apm can do arming without Radio Calibration.

      Thanks,

      Cherry

      • I think you need to press the safety switch first before arming. have you do this procedure?

  • Hello Everyone!


    Sorry for the late notice. I've already loaded firmware to the pixhawk successfully! Thank you so much for your comments. :) 

    I've unplugged the peripherals connected except for the safety switch and the buzzer, as what ItCanOnlyBeJared adviced. I've used apm planner 2.0 at first, but still nothing good happened. I've also tried using QGroundControl 2.0.1 beta version for Windows, that is for upgrading the firmware and it works. It stops until 90% yet the status says upgrading was completed. And so, I've opened again apm planner 2.0 and connect pixhawk on it. Luckily it connects but only at once. Connecting it for the second time, third, and so on doesn't work anymore. So, I again tried loading the firmware by using apm planner 2.0, and fortunately it was successful! :D

    After a very long wait hooohh! We just really have to be patient. :D I hope this could help. Problem solved! Another problems are on the queue. Let's just enjoy exploring pixhawk and see you guys on the next discussions!

    Kind Regards,

    Cherry

  • You should be able to flash your firmware properly with everything unplugged with the exception of the switch in some situations. Leave the buzzer plugged in too. That shouldn't interfere with anything at all.

    On my PX4, I tend to unplug everything since I hate the wires flailing everywhere. So I just leave in the buzzer and the safety switch.

    I tell you though.... These things are a pain in the arse.

    • Thank you so much. Your advice really helps! :)

  • T3
    I had issue loading firmware from my Mac running VM Fusion, so I switch to a real PC and it worked. I can access logs and parameter from the Mac, just not load firmware.
    • I have successfully loaded the firmware and I'm using WIndows 7. Thanks for the comment. :)

  • Hi I have the same issue I recently purchased a PX4 but have been unable to upload its firm ware. I have searched the forums and spent hours trying to get it to connect. I am now using APM2 after MP did not seem to work. The drivers (they say they are working properly), changed the SDHC used the battery to power up. I have the musical tones but it wont connect after I unplug and plug in same thing "attempting to find com port"

    I am about to try with out the GPS as this may be draining the USB port too much, other posts seem to have fixed this with the use of a powered USB port.

    Any advice here too will be appreciated.

    Thanks Gaz


    • Try unplugging the peripherals except for the buzzer and the safety switch. Loading the firmware on pixhawk is really one of the crucial steps but I know you'll get there! :) God bless you!

      Thanks for your comment,

      Cherry

This reply was deleted.

Activity

DIY Drones via Twitter
RT @chr1sa: My talk on PX4 and FAA certification is coming up at 1:45 PST today on the PX4 Dev Summit livestream. Includes some cool new st…
Tuesday
DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
Monday
DIY Robocars via Twitter
RT @masato_ka: 距離センサを3つとESP32を付けたラジコンカーをDonkeyCarライクにNNで自動走行。3層FC極小モデルをTensorFlow Lite for microcontrollerで動かしてる。機体は借り物でRumiCarって言います。Tenso…
Monday
DIY Robocars via Twitter
RT @SmallpixelCar: My car was able to go all the way autonomously until the crosswalk. It was only 100 yards from the target. What should b…
Jul 4
Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Smart move. The car used the shadow to guide it through the bridge. This was never in the training samples. But it learn…
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Getting closer to the target. Single camera. Untrained road. https://t.co/Wsr7RwDamj
Jun 29
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: #donkeycar https://t.co/czuLoVRcA4
Jun 29
DIY Robocars via Twitter
https://t.co/DKQbNTbz0g
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: Donkey car, car car car car car car; Donkey car, car car car car car car; Donkey Car. Anyone like our tiny tiny donkey…
Jun 29
DIY Robocars via Twitter
RT @SmallpixelCar: After improving DBSCAN speed, I can get 11 frame per second on @NVIDIAEmbedded Jerson Xavier MAXN mode and the autonomou…
Jun 26
DIY Robocars via Twitter
RT @Heavy02011: Join us at next Virtual Race League: ⁦@diyrobocars⁩ Race #4 - Parking Lot Nerds, August 1st https://t.co/5KUpu7VGaH
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: #CUDA implementation should be easy, because most of the time is on distance calculations berween two points and if the…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: This is the view from the car. Even my lanenet inference is fast on @NVIDIAEmbedded Jerson Xavier, DBSCAN clustering tak…
Jun 25
More…