CHDK usb trigger


I have a Canon S100 with CHDK, the E-flite EFLA600, Sparkfun step-up board and this cable

I have soldered and connected to Pixhawk. I can measure 3.3v pulses from the output pins of the Pixhawk.

The camera will fire when I disconnect the main Lipo battery. But I can’t get it to fire from Mission Planner.

Any idea how I can troubleshoot this?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok.  So it was a combination of things.   For my canon s110 I formatted the SD card using camera's tool menu for low level formatting (fat32) at 8 GB.  Set up card using Method 2:  Had to make sure the camera's firmware and CHDK version matched.  Also had to use the full version of the CHDK (attached).  Pixhawk was set up as:  I used the tuffwing cable.  

    s110-103a-1.3.0-4218-full_ALPHA (1).zip

  • Is there a way to look at the servo ppm values in Mission Planner to see if the PixHawk is working?  I suspect my trigger board or CHDK script is not working but I'd like to verify I have my PixHawk configured correctly before I just to conclusions.  -- Marcus

    Pixhawk Camera Trigger Cable for Canon CHDK Cameras
    • Attach a servo to the output - see if it moves in servo mode.

      For some reason, a lot of people have found that cables work when you have set trigger to "relay" instead of "servo"


    Try this; with some fairly simple programming on the board I can trigger my S100 using the camera control from pixhawk.

    If you need the code, I can dig that out of my home computer later.  I hacked it out of a program a fellow had posted on the internet (I'll try to find a link) and run the KAP script on the camera.

    Arduino Pro Mini 328 - 5V/16MHz
    SparkFun's minimal design approach to Arduino. This is a 5V Arduino running the 16MHz bootloader.
  • hello, I am using a canon sx230 with apm 2.6. I only use a cut usb wire - connecting GND & VCC to APM pins. I don't use step-up or any module in between.

    Have you tried to trigger the camera using the 'gear' switch on your transmitter?

    Have you set 'enable remote' in CHDK settings?

    If you are trying to use in auto missions, you have to enable camera trigger at set distances. I use Mission Planner

    • Damn....all that work for nothing....

      It works on APM because APM because APM has a 5V output. Pixhawk doesn't. Pixhawk is 3.3V. That's why we're having the discussion.  


  • Kevin,

    It's frustrating, but when you work out what is going on, it all makes sense.

    It's actually good timing that this has come up as we have just developed a board to solve the problem and we have a few pre-production prototypes hanging around and I would be happy to send you one.  Just PM me and I'll mail you one. NO PROMISES. NO LIABILITY - PRE-PRODUCTION!!!

    I have also attached our PRE PRODUCTION manual to this post. I would be quite interested to know if the instructions are good enough to help you;

    1) Understand why it's confusing.

    2) Let you configure the board successfully.



    Triggering CHDK from Pixhawk.pdf

    • Hi Joe,

      Thanks, but I have just received the Tuffwing cable and will try that first. The manual looks good.

This reply was deleted.


sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19