CLI access via Mission Planner is Impossible

Hi folks,

I'm trying to download the logs from the flash on the APM 2 (v2.73) using the CLI tool in doesn't seem to be possible.

I've tried the sequences below, but they all seem to be inhibited by the incredibly long connection process the Mission Planner undergoes, which is probably 30-45 seconds.


  1. MP open, at the terminal tab.
  2. Connect APM via USB
  3. Click connect on MP
  4. Spam <enter>
  5. Nothing happens on screen.


  1. MP open, at the Flight Data tab.
  2. Plug in APM to USB.
  3. Connect to my com port from this screen, wait 40 seconds for the MP to respond, then connected.
  4. Switch to Terminal tab.
  5. Nothing rolling by on the screen.
  6. Hit the Terminal tab button again
  7. Screen clears, then a chunk of the ArdupilotMega 2.73] prompt appears but does not respond to button pushes.

I can still use the MP conventionally without issue--for tuning and config and such.  Also works with the 3DR radio just fine.

This MP failed to upload APM firmware, too.  I had to use the APM patch of Arduino to get the writes to verify--MP failed every time.

As for alternative CLI access, I can get to APM's CLI with no issues via SecureCRT and PuTTY.  To avoid losing my logs from this morning's maiden flights, I'm just running dump out of putty and saving the mess into a .log file... I'm not sure what I'll need to do to graph and analyze this later, but at least I'll have the data.

So, I suppose I have to challenges to unravel:

  1. How do I get MP CLI to function reliably?  Whatever I'm doing wrong is rendering it useless.
  2. How do I trim and save these log files so the APM native applications (like MP) can read and understand them?  The interpretation tools are great!

Any help you folks can offer is much appreciated!


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I tried uploading 2.74b tonight and encountered this error--perhaps it's related?

    Untitled picture.png
  • New MP feature.  After terminal mode you have to reboot.  Click the button at the top left of the terminal screen

This reply was deleted.


Liam left a comment on Agricultural UAVs
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29