CLI access via Mission Planner is Impossible

Hi folks,

I'm trying to download the logs from the flash on the APM 2 (v2.73) using the CLI tool in Terminal...it doesn't seem to be possible.

I've tried the sequences below, but they all seem to be inhibited by the incredibly long connection process the Mission Planner undergoes, which is probably 30-45 seconds.

Sequence1

  1. MP open, at the terminal tab.
  2. Connect APM via USB
  3. Click connect on MP
  4. Spam <enter>
  5. Nothing happens on screen.

Sequence2:

  1. MP open, at the Flight Data tab.
  2. Plug in APM to USB.
  3. Connect to my com port from this screen, wait 40 seconds for the MP to respond, then connected.
  4. Switch to Terminal tab.
  5. Nothing rolling by on the screen.
  6. Hit the Terminal tab button again
  7. Screen clears, then a chunk of the ArdupilotMega 2.73] prompt appears but does not respond to button pushes.

I can still use the MP conventionally without issue--for tuning and config and such.  Also works with the 3DR radio just fine.

This MP failed to upload APM firmware, too.  I had to use the APM patch of Arduino to get the writes to verify--MP failed every time.

As for alternative CLI access, I can get to APM's CLI with no issues via SecureCRT and PuTTY.  To avoid losing my logs from this morning's maiden flights, I'm just running dump out of putty and saving the mess into a .log file... I'm not sure what I'll need to do to graph and analyze this later, but at least I'll have the data.

So, I suppose I have to challenges to unravel:

  1. How do I get MP CLI to function reliably?  Whatever I'm doing wrong is rendering it useless.
  2. How do I trim and save these log files so the APM native applications (like MP) can read and understand them?  The interpretation tools are great!

Any help you folks can offer is much appreciated!

spag

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I tried uploading 2.74b tonight and encountered this error--perhaps it's related?

    Untitled picture.png

    https://storage.ning.com/topology/rest/1.0/file/get/3692780693?profile=original
  • New MP feature.  After terminal mode you have to reboot.  Click the button at the top left of the terminal screen

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…