CLI access via Mission Planner is Impossible

Hi folks,

I'm trying to download the logs from the flash on the APM 2 (v2.73) using the CLI tool in doesn't seem to be possible.

I've tried the sequences below, but they all seem to be inhibited by the incredibly long connection process the Mission Planner undergoes, which is probably 30-45 seconds.


  1. MP open, at the terminal tab.
  2. Connect APM via USB
  3. Click connect on MP
  4. Spam <enter>
  5. Nothing happens on screen.


  1. MP open, at the Flight Data tab.
  2. Plug in APM to USB.
  3. Connect to my com port from this screen, wait 40 seconds for the MP to respond, then connected.
  4. Switch to Terminal tab.
  5. Nothing rolling by on the screen.
  6. Hit the Terminal tab button again
  7. Screen clears, then a chunk of the ArdupilotMega 2.73] prompt appears but does not respond to button pushes.

I can still use the MP conventionally without issue--for tuning and config and such.  Also works with the 3DR radio just fine.

This MP failed to upload APM firmware, too.  I had to use the APM patch of Arduino to get the writes to verify--MP failed every time.

As for alternative CLI access, I can get to APM's CLI with no issues via SecureCRT and PuTTY.  To avoid losing my logs from this morning's maiden flights, I'm just running dump out of putty and saving the mess into a .log file... I'm not sure what I'll need to do to graph and analyze this later, but at least I'll have the data.

So, I suppose I have to challenges to unravel:

  1. How do I get MP CLI to function reliably?  Whatever I'm doing wrong is rendering it useless.
  2. How do I trim and save these log files so the APM native applications (like MP) can read and understand them?  The interpretation tools are great!

Any help you folks can offer is much appreciated!


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I tried uploading 2.74b tonight and encountered this error--perhaps it's related?

    Untitled picture.png
  • New MP feature.  After terminal mode you have to reboot.  Click the button at the top left of the terminal screen

This reply was deleted.


DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord:
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident:
Oct 23