Computer don't see the Pixhawk

Hi everyone.
Got my Pixhawk but the PC do not see it. When I plugged it in to USB, the Pixhawk seemed to me gets alive, but the PC don't see the device, don't installs any drivers. I tried at two PC's and tree OS (Win 7, 8.1, Linux Mint), Mission Planner, APM Planner, Qgroundcontrol also installed, but the same result - PC don't see it. I also checked the USB data lines from the USB cable directly to MCU and it is ok. What can it be? Please help.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • My Pixhawk has the same problem as above and I can't find any solutions. Please help!

  • Have you figured out what was wrong?

    My PIxhawk also stopped working all of a sudden. The computer simply doesn't see it when it's plugged in via USB anymore

    1) Tried APM Planner on Mac and it doesn't show up as a connection.

    2) Tried Mission Planner on Windows and it doesn't show up as a connection. (even after re-installing MP with up-to-date drivers)

    3) On Windows it doesn't even show up in the Device Manager list.

    Unlike your case, my Pixhawk doesn't even seem to be booting up correctly as it doesn't have the musical beeping anymore and the large breathing LED doesn't even light up. In fact on Pixhawk boot up looks like this previous video (https://www.youtube.com/watch?v=Ewj71yqcAMw).

    If anyone has any advice, I'd really appreciate it.

    • No, I did not figured out what was wrong with mine, I send back the Pix to the seller.

  • That is what happening.

    https://www.youtube.com/watch?v=yCzs12kiWDg&feature=youtu.be

    Is this hardware or software problem? Is this bootloader problem? How to reconfigure anything from zero?

    What should I do?

    YouTube
  • Shot in the dark but make sure the micro SD card is installed. If it is then take it out and reinstall. Let us know if this works or not. 

This reply was deleted.

Activity

xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…