Earlier today I had the Mission Planner communicating perfectly with the APM (1.4). But now when ever I try to connect the usual window comes up and says "Getting Params.. (sysid 1 compid 1)". Then that stays for roughly 30seconds then I get "Connect Failed"

What is really interesting is that when I use HK GCS it connects no problem. 

I do have the baud at 57k and I have run the X-CTU on both XBees and everything seemed good there. What else should I try?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Any progress with the "Getting Params.. (sysid 1 compid 1)" error? I have been using for more than an year an APM 2.5 board with ArduPlane firmware. I used various ways to connect to the board: FTDI, Prolific, Bluetooth and 3D Radio. Everything was OK until recently after a Mission Planner update occurred. Since then, I could not connect with anything to my APM 2.5 board, well... almost anything, the USB connection still works. I have 2 different PCs (Win7 64bit and XP Professional) and I can't connect anymore on both of them after updating Mission Planner. I must mention that I disconnected the Minim OSD too.

    I tried to re-install Mission Planner and even downgraded the firmware on APM board ( I had 3.x and now I have 2.8.x), I reset everything to default)... no way to connect using something else than USB. I repeat, the issue appeared after updating MP on both PCs. The only thing to test is to remove all the wiring (aarrghhh, they deep inside the foam :-( ) and change the connecting wires.

    Anyone knows what the heck is happening? I have encountered this "Getting Params.. (sysid 1 compid 1)" scenario several times on forums and nobody came with a solution.

    Now it struck me that I could search for an older version of Mission Planner (I hope I will find one somewhere).I is very annoying, instead of flying and enjoying my good old APM I am struggling to make a lousy serial connection :(..

    L.E: I forgot to mention that yesterday I tried a new software for me, APM Planner (I did know about it) and it connected flawlessly every time, with no error. Anyway, I am interested in using Mission Planner as I am more familiar with it.

  • For a few days, Iv'e been trying to hook up a JY-MCU Bluetooth module v1.06 to the 3DR 433Mhx radio, as per Arthur Benemann's instructions.
    In order to reduce the 5V TX signal from the 3DR radio to the 3.3v level used by the BT module, I've used a couple of resistors (3.3V signal from BT module to 3DR radio should work).

    When attempting to connect from MP, the BT module's "not connected" blinking would hesitate for just a moment before MP drops an error.
    Testing from Android with Droidplanner and Andropilot was also fruitless.

    To test the link, I ended up creating a loop, connecting two terminal sessions, one to a USB connected 3DR radio and the other session to the BT serial port, in turn connected to the "remote" 3DR module. Something like this:
    PC  <>  3DR (USB)  <>  radio link  <>  3DR (Serial)  <>  BT module  <>  BT link  <>  PC
    Success - everything is working and there is no noticeable lag or delay. Even file transfer from one terminal to another was working.

    Last evening, I found this thread and the mentioning of the Ctrl+T connect command.
    Using Ctrl+T, MP now connects using Bluetooth without any hesitation. :-)
    Everything seems to be working and I have the same speed as when I use the 3DR module with USB (57600bps).

    I'm quite happy that it is working, but I am also quite annoyed:

    • Why do I need to use Ctrl+T from MP?
      It seems that it is not even trying to connect to the BT module (Timeout while waiting for BT to open connection?)
    • Why is neither Andropilot nor Droidplanner working at all?

    Does anyone have any suggestions? What have I missed?
    Should I replace the BT module with another, and if so with what?
    What should I try?

    (Obviously, I've been testing a number of different laptops and Android devices)

    I'm open to any suggestions.


    • Developer

      in MP settings, untick reset apm on connect.

      the bluetooth dongles dont seem to like using the dtr line.

      • Hi Michael,

        That was a quick response. Thank you!

        "Reset on Connect" is already unchecked :-(

        However, I just realized two other things:

        1. QGroundControl is also for Windows - not just *nix
        2. There is also an APM Planner 2.0

        Yes - I'm not too quick - right?
        (and yes, I'm kinda embarrassed) 

        I just installed both of them, and to my surprise, BOTH are able to connect using my Bluetooth-bridge-to-the-3DR radio without any effort - and with decent performance too. :-D

        Still, MissionPlanner (1.2.95), DroidPlanner and AndroPilot does not work :-(

        I was really hoping, but I have a feeling that my problem is caused by an initial delay when opening the connection to the Bluetooth module. (Well, that's the only thing I can think of right now.)
        BTW; Copter is running 3.1.2

  • Hi Michael Oborne,

    I am stug at the same point as all the ohters. The connect button allows telemetry to come trough for about 30 seconds and even a log-file is being produced. But then it quits as discribed so many times before. Using the Control+T solution allows to look at real time telemetry but does not produce any log-file. Without it in my case flying is useless.

    Last summer you asked:

    Can sombody test this by modifying the code.

    in GCS_Mavlink.pde around line 880


        if (_queued_parameter != NULL) {
            if (streamRateParams.get() <= 0) {
            if (stream_trigger(STREAM_PARAMS)) {




        if (_queued_parameter != NULL) {
            if (streamRateParams.get() <= 0) {
            if (stream_trigger(STREAM_PARAMS)) {


    Well I am willing to try everything to get it working but as a newbie I don´t have a clue what you are talking about. Can you explain where and how do I get to change the code or give a usefull link to a tutorial where I can learn to do so.

    Or, hey, did anybody else find a solution meanwhile? Is there a new firmware available? I am using ArduPlane V.2.78.

    Greetings from Bremen

  • I am having the same problem with low baudrate connections. It is definitely not a hardware issue. If i set low update rates and connect with ctrl + t i can get 50 to 70% signal. The SR0_PARAMS, param update speed, has no effect. This makes sence since it is never used in the APM plane source code! Why is there a param if it is not used?

  • Another +1 for a physical defect causing this problem. The middle socket on the cable that hooks into the APM had been nicked and when I plugged in the cable I bent the middle pin out of the way but didn't notice. I got pretty much the exact same error as the original poster. Figured it out, straightened the pin, carefully hooked it up and now it works 4.0.
  • I'm using a PX4 controller with RFD900 modems and arduplane 2.74. I seem to have the exact same problems.

    I tried default settings and a few custom settings. The same thing happens, the connection hangs and I get the no paramaters error. If I'm at the flight data screen, the HUD shows movement but it is very very slow. And then it just cuts out with the error shortly after.

  • Hi everyone. Iappologize in advance for this post. It's probably in the wrong place.

    I have had the "Getting Params.. (sysid 1 compid 1)" followed by a connection error for a long time now. I own two different 3DR telemetry modules, one works flawlessly the other produces this error (after working with two different APMs for a year or so). After reading through the forum and trying all kind of things suggested here i was ready to give up on the issue and toss the annoying module.

    At that point i looked at the TX-board again under a magnifying glass and noticed that one of these small SMD components sitting between the small board and the connectors has missing, cleanly burned off (Sorry i am not an electronics person).

    Funny thing is everything powers up, the RX and TX glow steady green and there is a connection because the software can get the parameters for the TX side wirelessly. So obviosly this component is not essential for most functions.

    But NOTHING else works. Control + T connects but there is no data received. Connecting with the connect button produces "Getting Params.. (sysid 1 compid 1)". The second radio works fine with the same settings on the same APM and the faulty module shows the same behaviour on an different APM.

      So maybe this error is really caused by a faulty component most of the time?

    Hope that helps. I appologize again if this is in the wrong place or otherwise rude. First post.


  • Well I tried every suggestion in this thread and still no bluetooth connection (which had worked well for more than a week with 2.8.1 and MP v1.2.41).  I upgraded MP (now I believe it is up to v50) and still no work around for bluetooth - and freedom from that damn USB cable. I need to calibrate and don't want to get "tied up".

This reply was deleted.