Connection Error in APM Mission Planner with wireless telem

Earlier today I had the Mission Planner communicating perfectly with the APM (1.4). But now when ever I try to connect the usual window comes up and says "Getting Params.. (sysid 1 compid 1)". Then that stays for roughly 30seconds then I get "Connect Failed"

What is really interesting is that when I use HK GCS it connects no problem. 

I do have the baud at 57k and I have run the X-CTU on both XBees and everything seemed good there. What else should I try?

Views: 10197

Reply to This

Replies to This Discussion

1. does it connect via usb? this will indicate a firmware issue or not.

2. HK's gcs does not require you to have a paramater list, this is why it will connect. My thought is that your rx line is working, ie receiving data, but your tx line is not, as when the planner requests the data the data isn't getting there.

1) It does work via USB. btw I am using the 2.4GHz module and baud of 57600

2) When I try to connect I get the message I mentioned then there is a details section which reads


Timeout on read - gerParamList 0 5 

Your serial link isn't fast enough


How do I check whether both Xbees are transmitting and receiving?

I am also a little confussed on what is meant by requiring a parameter list. When I connect via USB I can go to configuration and read/write params.

check your cableing, your rx line on your apm is not getting a signal.

I have exactly the same problem with a bluetooth module, I get the led lighning, but can´t get data back.

and after 30 seconds it crashed.

Over USB it works perfekt.


So I won't claim that the following is a solution, it is merely the last thing I tried before it started working. It may be unrelated. 


Then I turned all the data transfer rates (attitude, position, etc...) down to 1Hz and tried to connect. Connection worked. Then simply turned the rates back up to desired. Seems to be working. 

which data transfer rates do you meen?? Can you make a screenshot???

Same problem...

And your solution worked for me!


Tried your solution, but i have to do it everytime i have power up the system.
Also this is only a issue when i have arduplane v2.33 loaded, have tried with arducopter without any problems. so i think its a fault in the arduplane code.....

what telemetry rates do you have set?

57600baud on xbee 900pro

Hi all


Everything was working perfectly (5 months ago) and started to not connect more! I see that is a recent problem!

Can anyone help and set the cause of the problem? 


I have the same problem. No Xbee telemetry anymore. After clicking on connect, it tries to communicate then waits 30 seconds and finishes with an error message: 


Your serial links is not fast enough.


I tried "Brady D" solution and nothing changed. I changed the baud rate (in both Xbee's, firmware and MissionPlanner) to 38400 but still the same problem. Still not sure if it is a hardware or a software problem. I thought it could be a circuit noise so i disconnect all sensors from the board keeping only the xbee but that still not changing any thing. this disappointed me the who day.

I am using the flowing hardware/software:

Xbee modules: 2.4GHz XBee XBP24-AWI-001:

Xbee explorer on laptop side:

Xbee explorer on ArduCopter side:

ArduCopter firmware: ArduCopter-2.5.5

Mission Planner 1.1.92


Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service