Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


    • You mean you dont have the 29 option in rc9?

      I think the problem is a not a up to date Mission Planner.

      Just update, or manually type in 29 for rc9

      • Bjørn

        Thanks for your reply. I don't have the 29-option described under RC9, but like you mention, I can manually type it in. However I don't have the option for "Landing gear" under "Extended Tuning":

        Like the procedure describes, I'm supposed to choose "Landing gear" at "Ch7 Opt" or "Ch8 Opt".

        Best reg.


        • Hi Erik, just set ch7_opt or ch8_opt manually to 29, I think until 3.3 goes gold then MP doesn't pick up the new parameter options.

          • Fnoop

            Didn't realize that I of course just can set that option also manually to 29. Sorry for all the trouble, and thanks a lot for all the help.

            Best reg.


    • I have landing gear working in 3.3-rc5. I believe your issue is down to mission planner rather than the firmware. MP does not yet have the 29 value available under the RCn_FUNCTION parameters in the Full Parameter List/Tree screens. You just need to set 29 manually against whichever RCn_FUNCTION value you have chosen to use. It allows this value and works fine once set. Hopefully a future version of MP will include this value.
      • Paul

        Thanks for your reply and your explanation, but like I mentioned to Bjørn, I don't have the "Landing Gear"-option under "Extended tuning" when choosing "Ch7 Opt".

        Best reg.


      • Yes I had to do the same thing - set RC9_FUNCTION manually to 29 - and it works great.

        Does your landing gear go up automatically after takeoff?  The wiki page says it should but it doesn't for me, and I couldn't see anywhere obvious in the code that would make it do so.

        • I think Randy mentioned that if you had a 3 position switch, middlepoint was some sort

          of auto, but what it do i have no clue. Havent tried yet

  • Hi

    ublox GPS is not detected when i tried 3.3 rc5 on px4fmu+px4io. Works ok on ac3.2.1 though.

    used 3dr GPS + compass and quanum GPS + compass both not detected on 3.3 rc5 but detected on version 3.2.1

  • Yesterday I flashed the V3.3-rc5 to my PixHawk hexacopter, but now I can't get to download the log anymore.

    In the MissionPlanners (latest version 1.3.28) CLI it only gives "mumbo jumbo".

    In the beginning it says:

    Waiting for reboot

    Opened com port

    3Initialising APM...5? (NO mention of Arducopter 3.3-rc5)

    Then the mumbo jumbo starts.....

    What am i doing wrong?

    btw Arducopter V3.2.1 gave no problems. 

This reply was deleted.