Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


      • I think rc7 is a best firmware to the date. I will try to play with my hex tomorrow.
        Quad i played with today, and i could not make any control combination input to make it do anything wrong.

        Only issue i see is still with gps glitches when drone reaches the ground, it sometimes starts reajusting rtl position inches away from the soil, catches ground by its landing gear and flips. I think it is due to an error in baro readings or gps data - i noted sometimes altitude reading goes totall wrong saying, like, 3m altitude when i lower it down to just under 1m height, but it is hardware. Unless we get good reliable sonar there is probably little to nothing that can be done to make drone know it is inches away from the surface.

        Yet this issue happened only once. All other functions were great. Lift off is straight and smooth. No wandering about after lift off. I got it 100m into air, swapped to simple mode, flew all 6 modes, it landed back in rtl 30cm away from take off spot.

        Gps super simple mode still sometimes flips controls but as i stopped using it - simple mode seems to work just fine. Ma be super smle mode is not even worth keeping if it is impossible to prevent controls direction invert at close range.

        My 9yr old son flew it too, and is absolutely blown away. :)

        May be there is something bad in there. But compared to positive things i think it is a best firmware to the date. I crashed once in rtl as drone started readjusting position close to ground and got caught by landing gear but i think it is hardware, plus, it only happened once. I wish i had more time to help write this, but, so far it looks to be a truly great code. It is way better than old 3.2 and response to controls is really nice.

        I will try to link it with new banggood 3d storm32 gimbal, will see how that goes.
  • Why do I constantly get "error compass variance"? I'm testing on table, without arming, no 3d fix. Just connected and moving around. Also, on Mission Planner I see heading very slowly moving around while copter stand still. What is it?

    • Something magnetic nearby perhaps. I have magnetic tool holders on the wall by my workbench and if I place my quad to close, I get the same errors. Actually anything magnetic in proximity will cause that error.

    • Also, after calibration, offsets for the second compass was not saved. Is it ok?

      • I find sometimes MP does not report the offsets until you refresh the parameters.

  • how you all actually go back to 3.3-rc5?

    I tried to build ardupilot/arduCopter at revision "Copter-3.3-rc5". However there is no corresponding GIT tag in PX4Firmware, PX4NuttX and uavcan repositories. I tried revision tagged as "Copter-3.3" but get compile error. 

    GIT submodule is added after Copter-3.3-rc5 so I can't use GIT submodule to locate the rc5 revision in  PX4Firmware, PX4NuttX and uavcan.

  • tried 3.3-rc7 on PX4FMU+PX4IO but it is not detecting the GPS. on the mission planner it says GPS: NO GPS. but on 3.2.1 the GPS is detected. any special thing i should do so it will detect the GPS?

  • I flown my quad with Rc6 last saturday, everything seemed to be ok, except for the landing, my quad almost tilted upon triggering land. :) 

    by the way, which version of mission planner can you recommend, the official update or the beta update?

This reply was deleted.