Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


            • Great work, thanks!  Is it possible to retract/lower through auto mission commands?  That would be awesome.

              • Not yet, but hopefully eventually.

    • got it to work.

      for the RC output you need to select 29 as the option. Was not listed in the options in the latest update of mission planner so I guessed since 29 was listed for the CH option.

      I'm using CH 8 as my gear switch and aux1 as my servo output. In mission planner:

      Select CH8_OPT to 29 - landing gear

      Select RC9_FUNCTION to 29 - (unlisted function)

      Use LGR settings for servo throw and direction.

  • You could see the log

  • GPS on UAVCAN initial report

       I broke the cardinal rule and made two modifications at near the same time so have to dig a bit deeper to determine results.  I updated to 3.3 with no changes to PID tuning or any changes other than resident changes to 3.3, with that my carbon 550 quad flew better than I have ever been able to do in full sensor control modes.  I have had twitching problems in loiter since 3.2 and a couple of hard landings.  Now it is as stable and predicable as my Iris (my benchmark).  I have now flown several flights after installing a Zubax GNSS on the newly found UAVCAN Bus and have been impressed with initial results.  Two flights in GPS control modes under partial cloudy sky and sub .4 HDOP with >16 Sats resulted in repeated RTL's within inches of launch point and totally predictable rock stable loiter attitude.  We all know that HDOP and number of satellites is not the whole picture but flight performance indicates that the folks at Zubax have done a better than average job of noise isolation with the GNSS.  I have been using two other well know M8N units with slightly less results across the board.  At this point I think 3.3 made a big improvement in overall performance and the Zubax increased GPS accuracy without noise complications.  I'll be doing more in-depth testing on multiple platforms and will report any significant results.

    A big thank you to the Developer team and Pavel at Zubax


  • Upgraded to 3.3rc1 and it appears that the gimbal is not being controlled properly.  The Tarot gimbal on my 3DR Y6 works fine with 3.2.1 (RC tuning knob, ROI, etc), but the only time I can get it to move in 3.3rc1 is to hit the servo low/high buttons in MP.  Reverting back to 3.2.1 restores functionality.  

    It appears that others have seen this as well earlier in the thread, though with a different gimbal.

    Any ideas?

    • Still got the alexmos issue here with 3.3rc1... The Alexmos board connected to the Aux port in pixhawk was perfectly working in 3.2.x, as if it was just controlling a servo with pwm, but on 3.3rc1, the sAme setup fails to work, reverting to 3.2.1 restores functionality of gimbal...

      Other than that, the 3.3rc1 is way better than the previous firmware.
      • Developer


        Ok, this is almost guaranteed to be because of the changes to MOUNT.  If you set MOUNT_TYPE to 1 it should work again.  You're about the 4th person to hit this issue so I guess we need to do something to automatically set that parameter.  For now I'll put a note at the top of this discussion.

        • Randy,

          Actually, it looks like any servo based gimbal control is broken.
          I had a long try last night, setting mnt_type to 1, which should activate the servo based control again, but by using the RC11 for pitch, and RC10 channel for roll, I can't get any movement in the servo's which did work fine with V3.20.

          Also had a look at the MNT__DEFLT_MODE = 3, but to no avail... (Tried other values as well)

          I do power the aux ports externally to drive the servo's like I did in v3.20 as well.

          Even tried to hit the safety switch, to see if that was enabling the pitch and roll stabilization, moving the frame around...

          • Hi Randy,
            Ignore this one please..., by putting the RC control channels in MNT_RC_IN values, it started working like V3.21 again, when MNT_TYPE = 1

This reply was deleted.