Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    Copter-3.3.1 is out as the official release now.  Thanks for the confirmation from Miroslav, Yssaril, RandyB, JoeG, Stephan and perhaps a couple of others that -rc1 seemed ok!

    • OK that was strange.

      More on the 3.3.1 accel[1] not healthy messages

      So trying to figure out what was going on. I decided to clear my logs, then try again.

      I did the following:

      I turned on my RC transmitter (It was not turned on previously)

      I cleared the logs in the PixHawk.

      I waited a while, then rebooted the PixHawk.

      It seemed to complain about compass and other issues. So I re-calibrated the compass (at my desk, probably not best, but I decided to do it).

      I then re-ran the Accelerometer calibration, this time it walked through the '"place on left side, place on right side, etc."

      I even tried to arm (no flight battery) and then disarm. It all seemed to go ok.

      I had a lot of 'bad AHRS' messages, and the HUD in Mission Planner seemed wonky, it was showing the copter on its side, but it was level.

      So I rebooted the PixHawk, now the HUD shows level.

      AND NO more errors or warnings.

      Again, this is all while powering the pixhawk with my USB cable, no flight battery.

      So, am I ok now? What other tests should I make before trying to fly?

      Attached is my logfile, just in case anyone is asking.

      • I guess no one seems concerned, I deleted my logfile.

        • Developer

          Hard to say what happened but the accel[1] not healthy indicates a (perhaps temporary) hardware failure of one of the two IMUs (the LSM303d to be precise).  I'm not sure what we could do about that.  In Copter-3.3 it's possible to disable an IMU completely (INS_USE, INS_USE2 parameters) but it's not recommended really. Better to replace the board if one IMU is failing regularly.

          • Is this because it can't read values from the IMU? I get this also from time to time with my AUAV-X2. Usually disconnecting / reconnecting the battery cures it but it would be nice to know why it happens.

            • Developer

              Yes, it's likely that it's not responding to requests.  I'm more of a software person but perhaps it could be because the power is not coming up quickly enough or the board voltage is too low (i.e. if USB power cable or PC it's attached to can't provide enough power so voltage sags).  It could be a bad solder joint on the connection somewhere.

              • Thanks for the hints. I'll try this again with my flight battery. But other tests with the USB cable seem to be ok now.

                I've powered it up from the same USB cable a few times now and I haven't been able to repeat the issue.

                I can't say that it's gone forever, but at least I don't seem to have a hard permanent failure.

    • Thanks for all the Dev's work on the new release.

      So I previously was using 3.2.1 and it was working.

      I now loaded 3.3.1 on my PixHawk on my desk, only using my USB cable for the power to the PixHawk (as I have often done).

      The firmware flash seemed to go ok. I power cycled.

      I keep getting errors that I don't remember seeing before:

      PreArm: Accelerometers not healthy

      So I went to do the Initial setup, and tried the Accelerometer calibration.

      Then I get this error:

      Place vehicle level and press any key.

      Initialising APM...
      Initialising APM...
      accel[1] not healthy
      Calibration FAILED

      Ok, what do I do? Why do I get an accel[1] not healthy? I can't remember ever seeing this before.

      Or, MUST I test this with a flight battery, and not only powering the PixHawk with my USB cable?

      Thanks for any hints!

  • An observation.

    Yesterday I tried Auto Tune. The copter would not hold altitude while in Alt Hold, which is commonly reported by many. The AT was aborted and I discovered the vibration levels had worsened.

    Today after improving the vibration levels by > one order of magnitude, during AT the copter held altitude much better.

    Confirmation bias or a connection?

    • Developer


      Great that you got the vibes reduced that much.

      Bad vibrations will certainly affect AltHold performance.  It's absolutely critical and we recommend people designing/building copters to check their vibration levels (see First Flight section's Measuring Vibration wiki page) and the live vibration monitor added in Copter-3.3 was added to try and make doing this a little easier.

This reply was deleted.


Gremsy liked Gremsy's profile
Mar 12
DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video.
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022