Developer

Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

        • Developer

          Ok, Start out by setting these parameters.


          MOT_THST_BAT_MAX,25.2
          MOT_THST_BAT_MIN,21
          MOT_THST_EXPO,0.7
          MOT_THST_MAX,0.95

          To do a manual tune you want the feed forward off

          ATC_RATE_FF_ENAB,0

          Very carefully take off and gently make sure you have control over your copter. Start with tests at small angles like 5 degrees and work up to 20 degrees slowly. The way I do each test is I move the stick smoothly to the desired angle then let it spring back quickly. Check both roll and pitch this way.

          Set your Rate D term on your slider. Set the lower limit to your current setting and your upper limit to 4 times your current setting. Do 20 degree tests above and listen for oscillation. If you can increase it all the way to maximum, set that as the minimum and the maximum 4 times this and repeat. If you get an oscillation that looks like it might cause you to crash then simply move your slider all the way back to minimum.

          When you have found the point where the copter just starts to oscillate, back off so it just stops oscillating. Look at the value in mission planner and write it down.

          Now set your tuning slider to Rate P. If you don't do this now you will overwrite the value you enter for Rate D.

          Reduce the number you wrote down by 25% and enter it into Rate D.

          Repeat this process for Rate P. When you are done change to Stab P and set both Rate P and I equal to the value you wrote down less 25%.

          Repeat the same process for Stab P.

          This won't give you a tune as good as autotune but it will be ok.

          Now once you have tune Roll and Pitch like this you can use the input shaping to soften the feel if you like.

          Set

          ATC_RATE_FF_ENAB,1

          ATC_ACCEL_P_MAX,11000

          ATC_ACCEL_R_MAX,11000

          if you see your copter overshoot from a 40 degree test then you will need to decrease ATC_ACCEL_X_MAX. You may then decrease it further until you get the feel you like.

          If you want to tune Yaw then I really suggest giving autotune a go.

          Be very careful at all times during this process. On early flights just lift off by 20cm to make sure it is flying well. That way you can drop it onto the grass by cutting the throttle if you need to.

          Let me know if you have any further questions.

          • Hi Leonard

            I seem to have a problem initiating the auto tune mode.

            ON a great calm morning yesterday, I tried to do the auto-tune. 

            I have a switch assigned in the setup to use RC 7 and confirm in the radio setup that for channel 7, that it is going from the full low to full high pwm values when I operate the switch.  (980 to 1980 approx)

            I don't get feedback in the flight modes in MP that I am going to auto-tune when I operate the switch..

            Should I?

            I have made sure my trims are centered.   I flew in calm air and switched into ALT hold at about 20 feet.

            I flipped the switch and nothing happened.  Am I missing something that i need to do, and or is there a way to verify while still on the ground that it is going to go to auto-tune when I flip the switch?

          • Thanks a much Leonardthall

            After reading all that, I am reconsidering, using the auto-tune might be the way to go.

            I have set the switch before to do an auto-tune and it seemed to be right, but when I went into the air and used the switch, it didn't do anything.  I read later that if there was any trim, it wouldn't start.

            It is possible I had a click of trim in.  I made sure all my trims were nuetral and will try it again.

            Is there a way to confirm that auto-tune is set up correctly before the flight?

            With Mission planner, I can always confirm flight modes, but what about AutoTune?

            RE

  • I tried 'Follow Me' tonight. The quadcopter was quite jerky when adjusting it's position relative to my location. Is there a new setting that makes for more smooth yaw etc. when using 'Follow Me'?  This was after a new Auto Tune on rc5.

    In Basic Tuning there is a slider for pitch/roll sensitivity. Would sliding that left make things smoother?

  • I did a few more tests with rc5 and the RCMAP changes. RCMAP works great as reported elsewhere. Couple of things I noticed:

    1. I cannot arm in Auto. GCS says "Press safety switch" but the switch is already pressed!

    2. If I arm in another mode, switch to Auto and then try and run a mission starting from the ground, when I raise the throttle the copter immediately heads towards the first waypoint from the ground, rather than climbing to a safe distance and then heading towards the waypoint. I was in long grass and cut a swathe through it before it got to a safe height!

    I've not tried either of these before so not sure if they are new to 3.3, but both seem like bugs.

    • hi got no problem with 3.3rc5.on auto. i normally put takeoff on the first line and set the altitude and loiter time. succeeding lines are waypoints. last line is rtl
  • Not sure if there was an intended change in arming check but it appears that the safety switch check not always performed.

    RC5: in loiter GPS lock but compass issue (indoor testing), I can arm before enabling with the safety switch (ground station indication "armed") and due to EKF variance  it immediately switches to LAND mode. So actually the FC interprets the status  as ARMED too. Motors are not spinning - so the switch still does its job.

    • Do you have compassmot enabled ? if yes try to disable and restart this could solve the ekf variance error.

      • Actually I don't have any problem with it (only temp due to indoor conditions) but I do not think that Pixhawk should arm without the safety switch enabled.
  • i'm facing a strange behaviour and i'm hoping somebody can help me out.

    i have always an error message on the flight screen saying something like "GPS variance". Normally the error can be surpressed by disabling check_ekf_tresh. But obvious this is not the solution. This behaviour can lead to unwanted yaw rotations during take off -> pixhawk tries to correct the deviation which in reality is not.  


    what i noticed today is that the yaw heading is turning slowly counter clock with the copter sitting on the ground and not moving just sitting there. The deviation is growing more and more after a couple of minutes i have an deviation in yaw greater  than 180 degrees.

    Then i disabled compassmot just to see if this makes a difference and this solved the problem. i just set "COMPASS_MOTCT" to 0.

    this startet with fw 3.3


    Can somebody explain this ?

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…