Developer

Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Odd issue with RC8 and telemetry radio.

    I'm having an odd issue with RC8. I got my replacement hawk [it is a Hawk Lite] today and it comes with an oddball 3.3-dev firmware on it for quad. So I flashed it with 3.3-rc8 for hex and I lose the ability to use my Telemetry radios. It's a 4 wire air unit and when I flash back to 3.2.1 it works fine. Flash it back to 3.3-rc8 and it no longer connects. When watching the air unit on 3.2.1 you can see the data light blink as it should suggesting it is passing MavLink data fine, but on 3.3-rc8 there is no blinking at all suggesting it is not passing the mavlink data at all.

    I faintly remember seeing others with this issue in this HUGE thread but I can't find it using the search so I don't know what I need to do to enable it to work in rc8.

    I can't fly to test the new board until I am able to use the radios because I refuse to fly without them. 

    Can anyone point me in the right direction on this issue? I seem to remember it being something about CTS/RTS but the only air unit I have that supports that is on my X8 and I have 4 other air units but they are all 4 wire.

    Thanks.

    • This is weird. Seems that flashing it back to 3.2.1 and then connecting then flashing it back to 3.3-rc8 has fixed the issue for me as now it connects fine. Not sure how or why it fixed it but it seems to have and that means now I get to calibrate and test! Joy.

      • Developer

        Craig,

        There may be an issue with the auto detect of the flow control pins.  Setting BRD_SER1_RTSCTS or BRD_SER2_RTSCTS to zero will likely sort it out.  There is also a PR to fix the underlying issue but I'll need to test it first.  Maybe we need to put that into -rc9.

        • Thanks Randy for your prompt answer! I have copied this info and will post it on the RGC group for the Lite board just in case anyone else has this issue.

          I find it strange that flashing it back to 3.2.1 then back to 3.3-rc8 also fixed it as well though.

          And yes I would think that putting the fix into rc9 will go a long way in avioding having to answer this issue over and over as I am pretty sure I am not the only one running 4 wire radios :)

          Thanks again for the work around though!

          • Unless you changed some parameter in the process of flashing back and forth, the problem may still be there as it depends on timing and for me exhibits about half the time on 3.3rc7.  If you post elsewhere, you might want to include a link to the bug report I filed.  It has details about what causes the problem and a pointer to the pull request where it is fixed.

            https://github.com/diydrones/ardupilot/issues/2532

            It is interesting that more people are reporting problems that seem to be this issue than earlier.  It seems like either more people are testing the release candidates or the timing changed again in rc8 and the issue is even more likely to happen than it was in earlier test releases.

            Randy,

            If you have any questions or comments on the new code for flow control detection in the PR, I'd love to see comments there.  It has not gotten much attention yet.  I'm sure you guys are extreamly busy trying to get 3.3 finalized!  I did test the code rather completely before I submitted the PR.

            --Brad

            • I have 2 visually similar 3DR radio transmitters - one works fine with any value of BRD_SER1_RTSCTS, other one required CTS/RTS to be soldered in and BRD_SER1_RTSCTS set to ON, otherwise it would not start telemetry feed in 2 power ups out of 5, in average.

              With all that done as described it works fine at every startup now. I presumed it was something in the radio and not in the code, but, yes, I had that issue too.

              • Developer

                3702908644?profile=originalIt's a guess but I'd expect the two radios to have different settings for the RTS CTS checkbox.  Above is a screen shot of one of my 3DR radios and I'm surprised to find that it's unchecked.

                @Brad, I'll review that PR (or maybe Tridge will).  As you guessed, it's just a matter of time and I've been concentrating on trying to get the EKF and it's vibration resistance sorted out with Paul.

                • Not to mention you're running a REALLY old SiK version. 1.9 is the latest from Tridge.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
Monday
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
Sunday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
Saturday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Saturday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
More…