Copter being LAZY - not hitting Waypoints

My Copter isn't reaching Waypoints before the Mission Planner anounces it's heading to the next one. It seems like it gets quite a few Waypoints ahead of itself based on its GPS & visual position.

I'm using the latest Firmware & Mission Planner in a Quadcopter. My Wapoint Radius is set to 1 or 2.

For example I set up a Grid pattern (about 60m x 60m square) with Camera Triggers. It was just counting off the Waypoints almost as quick as it could announce them. I tried adding 0.5 sec delays at each waypoint but it didn't help much.

Then I tried a 25 metre radius circle with about 20 Waypoints. The Quad flew a 15 metre circle inside the Waypoints marked.

Am I doing something wrong or is this a trait of the Mission Planning protocols?

Photo: The Quad flew a circle inside the one planned.

Untitled.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • T3
    What the radius for you WPs? Try reducing the diameter of the waypoint radius.
This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…