Hello Everyone,

I am having trouble with my copter a few days ago, when I tried to test the failsafe feature of the copter.

I am using 4S 5200mah batter for my copter and my failsafe setting is battery voltage at 14V and RTL should be triggered when it hits that voltage. 

However as soon as the failsafe kicks in(actually triggered around 13.8V instead of 14V which I assume to be another problem)  my copter skyrocketed consuming about 40A (which normally hover at 9~10A) at failsafe voltage. 

HUD also displayed Error Position Vert Varriance. 

by looking at the log file, I found that there was enormous false altitude drop(my copter stayed same altitude)  as soon as  failsafe triggered for some reason. The reason why my copter skyrocketed is make sense since it tried to climb to the failsafe altitude while my altitude sensor reading at that moment dropped significantly for some reason. 

Does anyone has an Idea what could be wrong and how can I fix this problem ?

Thank you 

2016-04-22 15-15-28 BS outside test.tlog


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • It sounds like you have found the secret RocketCopter mode.

    now go do something about the crazy vibrations and other quality problems :)

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25