So heres the scoop. I had a well flying quadcopter using an APM 2.6. I decided to move to pixhawk. Bought a brand new unit from 3dr. Wired everything up and installed 3.2 Took it out to fly today and wasn't able to get it off the ground. The throttle and motors seemed to be acting weird and it sounded almost like a grinding sound. Keep in mind these motors flew through two batteries just the other day on my APM 15min flights each without a hiccup. The only thing thats changed since then is the flight controller. I brought it home and flipped the props and went to work trying to debug. I did the motor test in mission planner and ran each motor up to 15% throttle. Everything seemed fine, no weird grinding. So I got my camera out and started recording while I armed and tried the throttle. Again I was getting the grinding noise, then I noticed that above 50% throttle it seemed like no more actual throttle was being applied but the grinding noise got louder. I blipped the throttle a few times and sure enough it would seem thrust was coming up to the 50% point and then it was just making a louder grinding noise but not giving anymore thrust beyond that. SUDDENLY all the motors went to full power. No grinding noise anymore. I closed the throttle but nothing happened it was stuck wide open. I tried to disarm but it wasn't responding, so i took cover behind the bed as you can see in the video. The whole time I am trying to disarm. Eventually unsure of what my best move was I decided to turn off my transmitter. A moment later the motors returned to idle and I was able to disarm through my laptop (which I might have been able to do all along but in the rush I didnt think of it). 

To put it lightly, what the hell is going on. 

Video here, you can hear the grinding initially (warning loud)

https://www.youtube.com/watch?v=rID2jJInpgM&feature=youtu.be

Photo of the carnage below. 

7.BIN

LASTLOG.TXT

IMG_20141201_160240.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Ok, the motor sound indicates a wrong timing of the ESCs. This would explain why its fine with props dismounted and only appears while the motors are under load.
    Wrong timing can also be the case for the erratic throttle behavior. Could it be that you intended to recalibrate your ESCs after upgrading to the Pixhawk and thereby you accidentially entered into the ESC programming mode and changed the motor timing?
    • I doubt it. To my understanding Afros don't need throttle calibration so I've never calibrated them. I wired this up and took it right out to fly, so i'd be surprised if I somehow accidentally entered calibration mode, especially on a pixhawk where you need to do some special things with the switch to calibrate escs. 

  • The provided log displays motors properly follow RCIN.C3  - it's not pixhawk, but maybe your radio or RX that tried to kill you.

    I suggest you see Stephen King's movie "Trucks" for related clues :)

    To seewhat I do, plot RCIN.3 , and RCOUT.Chan1...4

    • Ya i'm kinda ignoring the throttle issue for now. Its possible that was user error as the logs seem to suggest there was input. That doesn't explain the grinding sound though. 

  • Well, when you have strange issues like this, take the props off and then do your testing. I couldn't see whether all motors are actually turning when the sound occurs and it's hard to tell whether all motors behave this way or not. If the pixhawk is the only thing that changed, it sounds like the receiver was playing well with the apm but not with the pixhawk.

    I'd do the following tests to see what you can learn:

    - remove the props

    - remove the signal wires from all ESC's from the pixhawk

    - turn on everything and track how the pixhawk is reading your throttle input. Then mess with the wires between the rx and the pixhawk a bit. If the connection there is a bit faulty, it can explain what's happening. You shouldn't see any glitches there.

    - Then plug in each ESC one by one and apply throttle just a little bit until the motor starts spinning. See how well it tracks. if the grinding noise occurs, then you can investigate the issue better. Without the props, do not apply 100% throttle or you can damage the motor by overspeed.

    - Then plug all ESC's in and see how you can make the speed of the motors track the throttle. Apply some bursts inbetween. Once again, do not apply 100% throttle.

    • The motors don't have the issue when they are unloaded. So the props have to be on. All motors behave this way. There is only one wire between the pixhawk and receiver since its ppm only. From other things i'm reading about motor sync issues I think my next step is to try adding a ground for the signal wire. 

      • It certainly sounds like a Sync issue to me.  EG: https://www.youtube.com/watch?v=5pBdDMxWsgs

        You absolutely should have signal and ground wires attached to your APM/Pixhawk..  Leave any BEC power disabled until you've sorted the issue.

  • So I did another test this time with lots of bungees. The motors are making a real obvious grinding noise. But it sounds like a digital grinding to me, like maybe the throttle output from the pixhawk isn't clean or something? I run up the throttle here and you can hear the obvious grinding. Then I do the motor tests again individually. Each motor makes the grinding noise when set to 25% throttle and tested. When I spin the motors by hand they spin completely smoothly and make no grinding sound, so im thinking it must be electrical/digital. These motors/escs were working perfectly fine with my previous APM setup. The only thing I have changed is swapping the APM for the Pixhawk and I also swapped my previous power module with the 3dr one that came with my pixhawk. Otherwise the motors, escs, power distribution is all the same. 

    https://www.youtube.com/watch?v=M2tH52ML3OY&feature=youtu.be

    • Could the propellers be loose and rubbing against the motor shaft?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Monday
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
More…