DCM Bad Heading

I have no idea what is going on.  Everything was flying great and then I updated the firmware to 3.2 and now I keep getting DCM Bad Heading.  This unit only flew 3 times before I put 3.2 on it and it was working perfectly with 3.1.  IT does not matter what mode I have the unit in I get this message.  The unit keeps flying but very rough then poof it passes and it flies normal again.


Here is the video file of what it says in mission planner as it flies.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hallo at all, I have today the same message.I post my log files , someone can help me maybe? Thank's a lot.


  • I had this problem after installing  pixhawk on a quad that had a pixhawk before with no issues so I knew it could not be proximity  to wires etc. I eventually re-did the compass-mot only 1/2 throttle not full throttle and that took care of the issue. Just an fyi

  • Dear Friend, 

    I suggest you recalibrate your compass or you isolate your gps and compass better from interferences :), look at ekf failsafe and DCM page on the link : http://copter.ardupilot.com/wiki/ekf-inav-failsafe/

    hope it help

    • Thanks, Chris. I did both those things with no luck. Then I had a closer look at my GPS mast. I had a crash a few days earlier and had broken the mast. I thought I had glued it back in place, but the glue didn't take. I think what was happening was the GPS/Compass was rotating relative to the quad from vibration, and the discrepancy between the compass data and the GPS/EKF headings was causing the error. I did a better fix on the mast and the problem is solved...

      Thanks again for the replies, guys :)

  • This happens when there is a discrepancy between compass heading and actual for more than a second. Move your gps compass module higher up on your frame away from batteries wires distribution esc's etc... Re do live mag calibration. Then also do a compassmot calibration. That should fix it.
    • Right on @pyrosamz did these two things and it has solved my problem.

      • Your most welcome rick. :)
  • I'm experiencing this as well on my 3DR 2014 DIY Quad running APM 3.2 on Pixhawk.

    "DCM Bad Heading," shows up on the HUD and error message is read out audibly as well...

    Total newb here, so any help is much appreciated.

    2014-12-27 09-48-52 18.bin.log

    •    I also got a DCM bad heading in my Mission Planner. It seemed to trigger a sideways movement and a momentary cutoff of the motors when I switched from Stab to POS  (I have been routinely taking of in Position hold mode before now with no problem.)  

      . Being only about 15-20 feet from the ground, it hit a rooftop of a nearby structure and broke a few things

      I have flow a few times with 3.2 without a problem, but this seems to have happened when I switched from Stabilize mode, to Position mode.  at the moment I flipped the switch is when it cut the motors.

      I had 11 satellites and HDOP of - 1.9 

      not good!    I've attached a flash log in case someone can take a look and understand what happened..


  • this is happening to me also.

This reply was deleted.