Did I just kill my microAPM? (Flasing only red)

Just after I cut the SJ10 thing to make it use outside compass it now is stuck and Initialising APM and leds flash only red. (it was led, yellow blue before)

Reflashing worked, but didn't help.
It seems to stop at downloading 33% of the paremeters when connected to APM planner

I tried cutting SJ10 few times, always to find it still uses the internal compass.
So today I tried harder and as you can see I got a little out of the square.

Did I just kill it? :(



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Here are couple images where I did better job at the macro shot

    I've clearly cut some more tracks right?

    Is it fixable?

    I was 5 mins away from flying and this happen. I almost cried a little, lol



    • Ok images still don't show up. Seems like server side problem.

      Here are the images for anyone curious enough :(


      • Did you use a chainsaw ?  - it seems so.  :)

        The damage itself is fairly easy repairable for anyone with fine soldering equipment and experience.

        It probably could be repaired even easier, if it was an 3DR device with actually open hardware (and downloadable schematics)

        • lol you made me smile :)

          First 3 times I was very gentle, every time I powered it it was still using the internal compass, so not cut

          So 4th time I went John Cena on it and this is the result :)

          yes i'm an idiot

  • fyi: unable to see your attachments

    • I think it's server side problem but let me try again.

      In short, only red leds flash,  blue and yellow doesn't appear



This reply was deleted.


sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24