DO_CHANGE_SPEED Doesn't Appear to Work

Hello, I'm attempting to use DO_CHANGE_SPEED to change the speed my Iris travels from one waypoint to the other. I've tried changing the values in both first and second columns, but they are not having any impact on the horizontal speed. Attached below is a screenshot of my flight plan. I'm using APM v3.2. I tried putting in very low numbers to almost stop the quad, but they don't have any effect. As you can see in the screenshot below, the ground speed is showing 1.32. 

Any ideas?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • T3
    It should say made the WP.
  • T3
    Your WP radius is way to large. I'd be surprised if your copter flys correctly between WP. WP radius should be set to either 2 M or 3 M. When the copter hits the radius it assumes is mad the WP
    • Rich...are you replying to me?  (Bill Salopek)...

      My waypoint radius is 2m.

      And the hexa flies great between waypoints.

  • I am having the same problem. (3.2.1)  

    DO_CHANGE_SPEED has no effect.

    In my case, WP_NAV_SPEED is set to 5m/s (500cm/s)...

    I tried to command 10, 15, and 20 m/s in my flight plan (I assume the FLIGHT PLAN "speed" box uses METERS per second (as defined in Mission Planner / Config Tuning / Planner / speed units), and not cm/s, correct?).

    But the hexacopter flew at about 5m/s the entire route...I had assumed the FLIGHT PLAN's DO_CHANGE_SPEED would over-ride the WP_NAV_SPEED?

    What's not working?

    Also, why are there TWO boxes in the flight planner for "speed m/s" next to DO_CHANGE SPEED?  Do they both need filled in to the same value?


    • Found out a couple things:

      The two-box thing is a bug...the speed needs to go into the SECOND speed box...the first box can be left blank.

      The DO_CHANGE_SPEED will not exceed the value in WP_NAV_SPEED, but DO_CHANGE-SPEEDs SLOWER than WP_NAV_SPEED will work.

      Is this true?

  • First: the fix I mentioned, is for those who have EKF enabled.

    Then: yes it's m/s  , and finally, there was a lower limit of 1m/s - I am not sure whatever it's still the case.

    • Hi Andre, thanks. I'm using ArduPilot 3.2. Any suggestions on where I could look in the code for a minimum speed (if any)? Also is EKF enabled by default or is the DCM the default option for sensor fusion?

      • you mean ArduCopter ?  - check out WPNAV_SPEED or WPNAV_LOIT_SPEED

        the EKF related bug I mentioned, was related to changing speed in a mission using DO_CHANGE_SPEED , and does not affect general setup.

  • I thought the speed was supposed to be entered in m/s. Your input says "0.01,0.02" for the DO_CHANGE_SPEED command, the values are probably being ignored. It works fine for me, write a speed in m/s in the second column.

    • I'm aware it is m/s. I tried various values - 2, 1, 0.5 etc. Can you try 0.5 and see if it works for you? I'm capturing low altitude aerial pics and there needs to be sufficient overlap between captures, therefore the quad needs to move slowly. Is there a minimum speed requirement? 

This reply was deleted.