I had EKF disabled until recently.After I enabled it by setting AHRS_EKF_USE = 1 , I see no change. 

The EKF and Vibration status displays which are available on clicking on the HUD are not getting updated. The levels are all like this- 

I have tried to induce vibrations, got an external magnet to change the magnetic field around the compass. I can see that the pixhawk is detecting them in the status tab below the HUD where the corresponding values change. 

However, the EKF status does not change on this window. Am I missing a setting or something any where? 

Any Help would be much appreciated. 

Thanks. 

Setup - Pixhawk with mission planner ,Arduplane 

Views: 172

Reply to This

Replies to This Discussion

If you are enabling AHRS_EKF_USE, then you are using firmware 3.2.x and below.  I understand that the EKF and Vibe options on MP will only work if you have firmware 3.3.x and above installed.  In copter, EKF cannot be disabled by that flag.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service