Hi all,

I seem to be having problems with calibrating my speed controllers.  I am building a y6, and using Red Brick 30A ESCs (I regret going on the cheap with the ESCs).

The auto calibration didn't work at first, so I did a manual calibration of each ESC, or at least I think I did.  There is a lack of documentation with these ESCs, so I am not sure the standards high throttle, power on, low throttle sequence works.  I think it did, because the auto calibration worked after that. 

I am able to power on, arm, and spin the motors now.  They all seem to be responding the same.  I am concerned however, because I cannot get the CLI motors command to work.  One time (in between multiple times redoing the auto calibration) I did get one (only one) of the motors to respond to the test, it responded each cycle through.

Any advice?  Has anyone used these ESCs?  I bought them because I had heard they are hobbywing pentiums, and I believe they used to be, however HobbyKing has changed the esc and used the same branding.  They are NOT standard pentiums any longer, I am unsure what they are.

They are based on the ATMega chip, so at some point I am going to flash them with simonk's firmware.

Thanks in advance.

Views: 2252

Reply to This

Replies to This Discussion

I did the same thing I used the HK.com SS 30A and I am not getting the confirmation beep on the throttle down during the auto calibration but it seems wo work and fly well. I never tried the cli test on the motors but the quad flies well... I really like it. 

I have a set of turnigy plush 30 amps I might be replacing them with not sure yet. I may leave them until i see a reason since they work as of now.

I have done some digging this evening, and am about 95% sure that these "new" Red Brick 30A escs are a HK SS 30a in different shrink wrap.

I have the SS ESC's and they work just fine....I mean theres no Documentation like you said but....

I know for the auto calibration when you plug it in the second time (with the radio still at high) they beep Quite a few times rather then once or twice, but as soon as I bring the throttle down they beep One last time and all is good...IF you want me to try anything on mine for verification I would be happy to help However........................I have not had a red brick to compare them against so Id be going on your assumption that there the same....(and you know what they say about assumptions)

You might need to reprogram the esc.  Check the HK website for the programming guide (it should be under the files tab on the product page) and youtube for some examples of programming it.

Perhaps your attempt to calibrate accidentally changed some of the settings.  Make sure it is not on "soft" acceleration.  Switching out the firmware for known good firmware is certainly another good option.

I have since flashed the ESCs with simonk firmware. All seemed well for a short time until one let out the magic smoke. I have given up on these Red Bricks. HK had the BlueSeries 30A in stock in the USA warehouse, so I ordered a set of them. They are N-fet only, with an ext oscillator.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service