F550 hexacopter MAJOR set back!

Hey gang,

I recently upgraded to the APM2.0 for my aerial video platform (F550 clone from Hobbyking). I followed all instructions and brushed up on my PID tuning skills, but on my maiden flight the helicopter had some seriously strange characteristics. First of all...here's my setup:

APM 2.0 with v2.6 firmware

F550 clone with integrated PDB

6x Turnigy Plush 30A ESC

6x NTM 2830 750kV motors

Turnigy 4s 5000 mAh 

Gemfan 10x4.5 props

Dx7 Tx & AR7000

AeroXcraft landing gear/camera mount

Pretty standard setup really. Now - as for the strange characteristics: on take off the copter had odd drift, very unstable yaw, very unpredictable throttle response, and it was generally un-flyable! I've gone through some PID tuning troubleshooting with the help of some folks on this site, but still no headway. After reaching a point of complete frustration I decided to revert to my last known flyable settings with my old HK KK2.0 board and HK Orange 6 ch Rx. Thinking I'd at least be able to get off the ground and have some fun until the new 2.7 firmware releases this week. WELL, I had the same problems but even more exaggerated! Terrible throttle response, weird pitch and roll issues (poor stabilization with verified settings from several days ago), and yaw was all out of whack. I've re-calibrated the ESC's both manually and automatically, checked prop rotation, board orientation and firmware, etc etc etc. I'm really flustered and don't know what else to do! Any help is greatly appreciated!

Cheers!

Will

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I think this case is closed! After a lot of self inflicted hair loss I figured it out. 

    All my troubleshooting lead to the direction Rui went with his most recent suggestion. I deleted some extraneous models in my DX7 and started from scratch. I set up a new ACRO model with no mixes etc and low and behold my KK2.0 board came to life like it was before I tried installing the APM2.0. I think where I went wrong is when I tried to set up the CH. 5 flight mode switch..I must have altered something in the Tx and made the thing go crazy! I'm anxiously awaiting the 2.7 firmware for my APM then I will re-flash and try to get my bird up in the air with the APM. 

    Can anyone direct me to a thread for setting up my DX7 the correct way so I don't run into this issue again????

    Thanks for all your hard work and insight, don't know what I would do without this support group!

    Will

  • Hi Will,

    Have you confirmed your radio is in ACRO mode and no mixes are active ? (do not use HELI mode)

  • do you have video of it flying?

    just trying to think of the most likely things that could have happened since you last had the HK board on there - if youve suffered a few bumps with the ground your props may be off balance and causing vibrations.  other than that perhaps the motors are slightly misaligned?

    james

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
Friday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Jan 16
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…