Hi all,

I'm running into some curious issues with my quadcopter build. The problem is that when I attempt to do the radio configuration in the Mission Planner (I'm using version 1.2.34 Mav 1.0) I get no green bars at all. Calibration does nothing and it appears that the arduino is not receiving radio signals. However, when I test this by plugging in an ESC and a motor to each channel, I can spin all of the motors up. Then, in the Terminal in APM, I run the Radio and the PWM test. During the PWM test all 4 of my channels work and display values which seem to be normal (1000-2000) for each channel and change corresponding to the transmitter. In the Radio control, only 3 of the channels (1, 2, and 4) seem to change any of the numbers. Those numbers change over 16-bit signed values (-32,000ish to 32,000ish)... I'm quite confused as to why I can get data via PWM, 3/4 of the data through the Radio test, yet none of the bars work with the APM radio configuration. I have reinstalling the APM and updating to the latest versions as well. Any ideas what's going on?

Thanks so much,
-Alex

Views: 4546

Reply to This

Replies to This Discussion

Hi, I'm kind of having the same issue as yours, I'm gonna paste what I said in an other post maybe this is a better place to get a reply.

Hi guys, donno if I'm doing something wrong and maybe I missed a post about this but I'm having issues with the new APM2.5 I recieved a couple of days ago. I manage to connect to it with M/Planner over USB but no flight data information and not even radio calibration works. On the other hand I can perform calibration/modes and even Mag/sonar/gps tests from CLI. When I connect with Xbee everything works(except CLI). The old APM1.4 works fine over USB/Xbee. So What am I doing wrong? Thanks

@Alex,

Did you try the Terminal radio calibration in the CLI setup? Works for me and I get the green bars using the MP 1.2.34.

Regards,

TCIII

I have tried the Terminal radio calibration in the CLI setup and it seemed to work. Even after doing that I still don't get any green bars though. Can I just use the Terminal radio calibration from the CLI and skip the step with the GUI (green bars) when setting up my quadcopter?

I still haven't managed to find out why it's not working. I've used 3 different versions of MP as well as different versions of firmware for the quadcopter.

Thanks for the reply,

-Alex

Hi Alex,

I believe you can skip the GUI and it seems like we do have the same issue, does your flight data tab give you any data when you tilt/move your APM because mine doesn't. Can you try connecting with Xbee and see if everything works?

What I want to know from the experts is if its a Hardware/Software/User issue because this is a Brand New APM and have to decide if I should send it back!

Thanks

Steve

@ Steve

I'm not using Xbee, so I won't be able to help you there. I'll check the flight data tab later tonight when I get back to my place, but I don't recall seeing anything.

I'm glad to see other people seem to be having the same issues. Hopefully we can get this resolved soon.

-Alex

Alex,

I managed to workaround my issue. Go to Configuration>Planner and uncheck "Reset APM on USB connect".

I'm still not happy because that setting is there and turned on by default for a reason so I think I still want to know what is going on.

Steve

Hmm unchecking "Reset APM on USB connect" does not appear to help my situation at all...

Thanks for the idea though.

Alex

Another thing I've noticed is that when I am using the Terminal CLI: if I type "logs" my board does not seem to respond and seems to hang in some loop. It never does anything until I click back on the "Terminal" button back at the top of the AMP Mission Planner.

I don't know if this is related in any way but thought I should mention it.

In addition to this I get this message when I open the Terminal connection:

"load_all took5t308us

3No dataflash inserted3AP_Motors: failed to create the throttle curveCOMPASS INIT ERROR"

Then if I go into test and enter data logging it says:

"Testing dataflash logging

ERR: No dataflash inserted"

This appears to be the reason behind my problems. It would explain why I could read in the pure PWM values from my RC, but couldn't read them on the Mission Planner (because presumably the data is stored in flash memory first before being sent over USB to the computer).

Anyone else agree with my diagnosis? Any other ideas? 

I've inspected the chip and it appears that all the solder joints are solid, so it's not an obvious hardware defect....

-Alex

Hi Alex, I gave up and agreed with the seller for a replacement, now all I have to do is WAIT, for it to get here, AGAIN. Did you manage to get yours working ?

Steve

I've notice that sometimes you need to click "calibrate" before the bars will display. And sometimes you have to wait a few seconds. If all else fails, closing the MP and restarting it always does the trick for me.

I did not. I did find out what is wrong though. Turns out my unit was dead on arrival with a bad flash memory chip. That was causing all of the issues.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service