Forever yawing

Had a crash and now when connected to mission planner yaw is continuously changing.  It starts at 360 and counts down.  I created a short video showing this in mission planner.  Flying is of course impossible, the copter just starts to yaw out of control.

Any suggestions to fully diagnose this or correct it?   I suspect the gyro is messed up.  I read about reflowing but would appreciate more details on how to do this.  I do have a heat gun.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • My quad is doing the same thing as well...

  • My problem is more than just what is shown in Mission Planner.  When I attempt to fly, the copter yaws immediately in a fast spin.  I had been flying for a few months without a GPS and without a mag with no issues and I never noticed the forever yawing in MP.  So I assumed what I saw in MP and the spinning during flight was related.

    I tried with 2.0.48 and saw the same yaw in MP.  Though I haven't tried to fly with this build.

    The drift is about 1 degree a second but always in the same direction.  I guess if left long enough it would go all the way from 360 to 0.  Not really a drift... just a countdown.

    I will add a magnetometer this weekend... but I doubt that will change anything.  I really think something is busted from the crash.  I actually have tried a second oilpan yet still have the same results.

    As Todd mentioned... how do I do this: "erasing the offsets and starting over".


  • I have met the similar problem, I think if it oscillates with in 1 deg should be OK to fly, but the performance is not quite well.

    By the way, my board was purchased quite long time ago, I don't know whether the latest code can work well on it....

    I suggest u to go CLI test to test the compass and imu, if that is OK, then try to use some old version code...

    I am not quite sure whether PID settings will help.. 

  • I've had similar problems ever since we updated to 2.055, with the problems persisting in 2.1, and seen other users with similar yaw problems (an maybe related roll or pitch problems). 

    I was able to get the problem to go away in 2.055 by resetting and erasing eeprom, reinstalling firmware, and re-doing setup. However, I'm having problems getting the same to work in 2.1. Based on my observations, it seems to me that the problem has to do with the compass offsets. It seems that bogus numbers occasionally get created and then a permanent yaw develops, which can only be solved by erasing the offsets and starting over. I don't know if Jason changed the code related to how the offsets are created in these newer firmware versions, but that might be a place to check.

    I could be way off base, but I've seen enough similar problems from others to think that it might be a bug in the code.

  • Developer

    Sounds like you don't have a magnetometer, it's not enabled or perhaps it's broken.  Gyros drift so you normally need the magnetometer to counteract that.


    I couldn't actually see the heading in the video :-(.  Isn't it right at the top but just out of view?

  • I am having a similar issue, I noticed that if I reload the code, setup the radio and everything without turning the APM off, it works fine, i can even fly. But as soon as I restart the APM the yaw gyro isnt taken into account it seems. The IMU test works great, but the APM doesent incorporate the gyro data into flight.

    I am working on it now, I'll let you know what I find.

This reply was deleted.


sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24