Garbage from Serial?

I just got around to testing out my hardware after I got my frame assembled for my quad. I unplugged everything then plugged the USB cable in to both the ArduPilot2560 + Oilpan and my computer. The driver installed just fine (Windows 7 x64) and came up as COM4. I went and set the bits per second to 115200 and went to the advanced options and enabled the "Set RTS on close". Opened up APM Planner 0.4146.32782 and tried to open up a terminal to make sure it was working. What I found on the terminal was a bunch of garbage data like so:


Opened com port




I tried rebooting. I tried using PuTTY and got garbage data on it as well. I checked all the solder connections and they look good. I've got some experience with soldering so I'm fairly certain that's not where the problem lies. Can anyone help me out?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • aha!!! so finally it worked....

    thanking you "Alpha" for the guidance and help!!! God Bless You!

  • i don't know why but i tried everything you told but it still throws garbage..... :-0

    • 3D Robotics

      The CLI is no longer supported, and the terminal is just showing binary MAVLink. All former CLI functions are now available via MAVlink commands in the Mission Planner. 

      This thread is four years old. Old info!

      • hi chris,

        thank you very much for your prompt reply.

        i don't know what went wrong with my APM but after the Mission Planner got updated last week everything went KAPUT!!!

        the UBLOX GPS is not showing the Blue blink light any more... its just the Solid Green for power. Also my telemetry stopped communicating completely. The APM fails to arm. it's just unleashed a long line of issues since the update.

        any idea why??

        • Even i too suffered it and made my GPS blink back, initially I updated my GPS with 3DR-Ublox.txt from through APM2.6 and u-center_v8.17and this doesnt works for Ublox NEO-6m. Now I uploaded the right file and it is blinking blue. The right file for Ublox Neo-6m is attached below


          • ok got it.... download the U.Center...

            hope it works!!! :) fingers crossed!!!!

          • thanks for the reply.

            how did you upload it?? from where?

            • ok got it...

              but i am still getting download link for U.Center...

  • I got the same plroblem fixed. At first Mission Planner HUD was ok, flight data and settings ok. but console CLI was fully of garbage.

    1- Go to Device Manager -> Select 3DR Tx as "USB Serial Port (COM##)"
    2- Properties
    3- Port settings Tab
    4- Set baud rate to 57600
    5- Accept, done.

    This works for me.
    PD: I have Windows 7 x64

  • Developer
    have you uploaded a firmware?
This reply was deleted.