Garbage output mixed in w/ overlay MinimOSD

Here's what I'm running:

GoPro

MinimOSD w/ ArduCAMOSD_19_MAV10.hex

APM2 w/ 2.6

It _sort of_ works...in that it works fine, but in areas where there is NO overlay activity, there are garbage characters overlaid.

When I power up the OSD, at first I get a clear video feed, then as soon as OSD starts to boot, I see this garbage anywhere there isn't OSD generated overlay.  Everything else works fine. 

I've re-updated the firmware, and even tried dumping on the newest .mcm charset I could find, which made no difference.  I'm NTSC but I've tried the settings for both w/ no difference.

I've searched around a bit and can't seem to find any posts about this occuring w/ other folks.

Ideas?

Thanks

3690943078?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Actually in the new firmware is not possible disable OSD by screen switching so I load my previous firmware (MinimOsd_Extra_Copter_R800.hex) and it works now great again...

  • whohooo, finaly, I was able to get it work when I load new firmware and charset from the https://github.com/night-ghost/minimosd-extra.

    night-ghost/minimosd-extra
    Full rework of minimosd-extra with lots of news. Contribute to night-ghost/minimosd-extra development by creating an account on GitHub.
  • Same issue. I tried 5V trick and reload firmware + charset and no change :(

    Any other ideas ?


    3702325930?profile=original

  • Has this problem been figured out yet? this problem just showed up on my osd screen.

    • I had the same problem. I am not sure what caused it but i fixed it by reloading the firmware and charset.

      • That worked a few times for me. The flicker got worse and the garbage on screen came back when I was at the field. Also try rebooting by unplugging the Pixhawk from the MinimOSD board. That will work a few times, too. When you get sick of all that and not flying...

        • Did the 5V conversion and same garbage on screen. Rebooted OSD, same result.  What can I try next?

          • Did you reload the charset after the fix? I think it actually corrupts the charset, so even after it is fixed, it needs one more charset update. Report back if this works or not. Just to clarify what I meant by unplugging it from Pixhawk, I meant unplug it while it is powered up. That helped some of the time. Do any of you guys see the flickering as well as the garbage?

            • No flicker just garbage. I'm waiting for a FTDI board so I can reload the charset. I'll let you know Tuesday how it works-out. Thanks!

    • It has not come back since I converted to the 5v configuration. Use the diagram in the last figure on this page:

      http://copter.ardupilot.com/wiki/common-minim-osd-quick-installatio...

      I think the problem is with the regulator. In the 5v config, it does not use the regulator. It is kept separate in the 12v config to isolate noise, but I see no noise difference in the 5v config.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
yesterday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
yesterday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
yesterday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31, 2021
More…