I just wanted to check if someone had the same problem after updating the mission planner, I am no longer able to geo ref images. I have tried to georef in three computers all running the latest version with no luck. I was only able to geo ref in the fourth computer not running the latest version of mission planner.

The error I get is this:

Reading log for CAM Messages
Log Read with - 302 - CAM Messages found
Read images
Images read : 302
Error System.FormatException: Input string was not in a correct format.
   at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
   at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
   at System.Int32.Parse(String s, IFormatProvider provider)
   at MissionPlanner.Georefimage.doworkCAM(String logFile, String dirWithImages) in c:\Users\michael\Source\Repos\MissionPlanner\georefimage.cs:line 1110
   at MissionPlanner.Georefimage.BUT_doit_Click(Object sender, EventArgs e) in c:\Users\michael\Source\Repos\MissionPlanner\georefimage.cs:line 1580

Is this a known issue and does someone know how to download older versions of mission planner?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Confirmed. I get the same error on the two most recent mission planner builds.

    Re-installed 1.3.29 and the geotagging function works perfectly.

    Would be nice to have this feature fixed in the next update.

    • Although the issue with the Geo Ref Images utility in MP that was raised by the original poster doesn't appear for me in MP 1.3.32, I'm encountering new problems with this tool I haven't encountered previously.

      With 'Use AMSL Atl' selected, the utility returns an error "Log file problem. Aborting..."; this error don't occur if the relative altitude is used. I'm using logs produced by AudoCopter 3.2_RC10, and wondering whether the new default position offsets of the altitude values in the log may have changed at some point? Does anyone know whether this is the case?

      As an aside, the Geo Ref Images Wiki (http://copter.ardupilot.com/wiki/common-geotagging-images-with-miss...) is no longer current.

  • I got the same problem and I get the same message. Did you solve it?

    • Not really no, I managed to find an old setup file for mission planner 1.3.19 and there I can geotag the images with no problem. Just keep saying no to updating the MP

      Have you tried uninstalling and download MP again not sure if the newest version is online or not, maybe you download the older version and than it ask you to upgrade.

This reply was deleted.