Glitch?

Has anyone else experienced a sudden and violent shift in direction whilst hovering?
Does this sound Ardiuno related or board related or ESC related? Or perhaps a Tx/Rx issue.

Regards,

Rich

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thanks will do - else this flies great, even with mixed escs dude to one being DOA.
  • I seem to also have a motor glitch; it is clear one motor (back right) drops out for a second and recovers - I think I will try and resolder all the bits and check again.
  • I think I remember reading in the ESC Spec Sheet, that the ESC will drop to half RPM in some situations (low current, high heat, signal loss, or low voltage/battery, etc) It seems reasonable that one isn't getting enough power and is dropping to half RPM. I also remember reading that it would drop to half RPM and then after a delay, would drop to 0.

    Could that be it?

    I think Im going to go add a ton of solder to mine now.
  • Could this be a function of not enough solder on the main traces of the power distribution board?
  • I've got a little more to this now....I had been running NG, and was able to get it in the air for 4 or 5 minutes, until a random mishaps as can been seen below.

    I went back and loaded the regular RC1, and couldn't even get off the ground due to the motors cutting out.

    It seemed that lowering PID values helped me in NG, but that doesn't really seem like what would cause this.

    I've had this happen randomly on all four motors on this quad.


    domain.strategi.st
    creating new opportunities, from great ideas to digital assets
  • use high quality equipment and it won't happen ;)
    I never had glitches or issues with my copter (just too much power but that's another story ;) )
  • YES....I do have a hitch in one of the motors that seems to occur randomly.

    When I hook that ESC/motor straight to the Rx, I can run a battery down with no problem with the motor.

    When I'm hovering, I get a back right dive every once in a while....going to triple check all my my connections, but something seems odd.

    I'm trying out the latest NG code from SVN. Will keep testing today.

    Perhaps ESC timing? Does anyone recommend changing the stock ESC timing?
  • If this was a normal RC helli, my first guess would always be the RX. Check it's positioning WRT the ESCs, and switch it out if you can.
  • Check your bulletconnectors and soldering between ESC's and motors.
    It could be bad connection.
    motors.it - This website is for sale! - motor,motors Resources and Information.
    This website is for sale! motors.it is your first and best source for all of the information you’re looking for. From general topics to more of what…
This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…