GPS not working

I have an APM 2 and the GPS functionality is not working at all. The blue 3d fix light never comes on, solid or blinking.

When I run gps in test from the CLI i get G! G! G!

The board is brand new and has never been flown, does anyone have any suggestions?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Luc

    I had a simalar problem to you with the APM 2 it was to do with the 6 pins not soldering the connectors properly on the top GPS board (my fault), after I had re-done the connectors all worked fine.



  • Took a dump of the command like and it does not look healthy:

    Opened com port

    Init ArduCopter V2.6

    Free RAM: 2370
    FW Ver: 118

    load_all took 4232us
    3No dataflash inserted3 COMPASS INIT ERROR

    Press ENTER 3 times for CLI

    G Q`'y !G QC^`'Z?!G Q.P`'?!G Q`'ic !update:35: gps read timeout 4944 0
    G 3Initialising APM...R
    `'8n !G Qs<`'> !G Q`'Q!G Q~`'A !update:35: gps read timeout 9749 4944
    G 3Initialising APM...sQ`'L !G Q-{`'3?Q#`'?!G Qg`'-V !G Qi`'!update:35: gps read timeout 14554 9749


    3GROUND STARTw Qx!`'3"Initialising APM...@ Init Gyro #Q$`'?* %Q&`'p?* 'QE(`'C IMU
    G_off: 0.01, -0.00, 0.03
    A_off: 0.00, 0.00, 0.00

    Ready to FLY )QK?*Quj +Q,Qd -Q.Q?/Q&?0Q?1Q?2QS 3Q+- 4Q] 5QF# 6Qx?7Q?8QvA

This reply was deleted.