"Guided" mode crash... Guided by whom??

Hello there,

I had a frustrating crash last night that's broken an arm and perhaps a motor on my DJI F450. This is my first quad; it flew well with 2.9.1b but I've rebuilt this several times recently trying to get decent performance out of 3.0.1. I haven't got an external magnetometer yet so I've spent some time tinkering with mounting positions and methods. Anyway, long story short, it was finally flying well with good vibration values, a nice solid loiter and accurate RTL despite compassmot remaining a little bit high, and I've spent a fair bit of time just learning to fly the thing well in all orientations in stabilise and alt-hold modes.

I've never tried Auto mode yet but last night I thought I'd have a go at Guided mode. I've set this to be one of my flight modes, according to the instructions in http://code.google.com/p/arducopter/wiki/AC2_GuidedMode
I realise now that this is different from the newer instructions at http://copter.ardupilot.com/wiki/ac2_guidedmode/ which says it doesn't need to be assigned to a flight mode (so why can it be??).

Anyway, I was in loiter, nice and steady, and flipped to guided mode. My expectation was that it would continue loitering waiting for me to tell it to go somewhere on the laptop. Instead, the quad immediately shot off, despite my not having told it to go anywhere yet.

I have an override switch for my normal mode switches that should go back into stabilise. What appears to have happened next is that I hit the override switch to get back into stabilise, it didn't seem to work, I flicked it back, off the quad went again, I panicked, and when eventually I got it into back into stabilise I had clearly somehow dropped the throttle (although I don't remember doing so). The motors didn't want to restart, and it crashed.

So, a couple of questions:
- Most importantly, why did the quad fly off as soon as I put it into Guided mode? Where was it off to? I hadn't given it anywhere to fly to, and it wasn't heading for the "home" position where it was armed. The GPS looks to have been ok. I know now that the Guided flight mode is deprecated and I should just use loiter, but surely it shouldn't be replaced by "Guided by Demons" mode??

- Does my diagnosis of what happened look reasonable? I don't know why I decided stabilise mode wasn't working as from lines 14420 to 14705 it kind of looks ok. I guess I got disoriented. But then at line 14705 it goes back into Guided (I think I tried toggling the override switch) and there is a strange divergence between RollIn and Roll; this may have been the point where I panicked and somehow lowered the throttle (too much practice on small trad helis where my  instinct is just switch off to minimise breakage!). What's going on here??

- This is (only) the second crash I've had with this copter and both have been ultimately due to the motors stopping and failing to restart (the other was when I was practising fast descent and recoveries). Both terminal descents have been characterised by the copter starting to tumble, and then not being able to get the motors restarted; last night they did but not soon enough. I know there's been some talk about modifying the code such that the motors always spin when armed. Would this slow spinning be enough to prevent motors stalling (given the up-draft) and tumbling and allow a faster recovery?

- Otherwise I can see two ideas to save from accidentally stopping the motors in flight. Either have my emergency failsafe mode to be alt-hold rather than stabilise (maybe risky if something goes wrong with that, though). Or program the transmitter such that zero throttle can only be achieved with a switch in a given position along similar lines to a throttle-hold switch on helicopters. Hold this to arm with zero throttle, but when it's released the throttle stick is remapped so the bottom of the travel gives say 10% throttle. Would there be any issue with doing that?

Thanks for your help!

2013-08-27 20-12 1.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • So does anybody have any feedback on what happens if you switch into Guided mode as a flight mode (as advised in the old documentation) as opposed to staying in loiter and using the MP / Fly To Here? This is what I did, and it caused the quad to fly to a seemingly uncommanded location.

    I've had a bit of a look through the Arducopter code and although I'm not familiar with it yet I can't see any place where this is handled, i.e. the waypoint navigator code is activated but I cannot see where it is given its waypoint, other than in the code which handles the communications from the GCS. So, if changing into Guided mode using flight modes as I did, it immediately navigates to SOMEWHERE but where??

  • T3
    You might try setting RTL to channel 7. When you get into a problem, flip the switch and back flys your copter. GPS lock is a must for this to work.
This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25