I have a H550 (f550 clone) 

Motors: NTM 28-26s 1000kv 

Props: APC Style 10x4.5

Flight Controller: APM 2.6

Rx/Tx: Turnigy 9XR Pro with DJT FrSKY D8R-II Plus

ESC: Turnigy Plush 30A

Logs: Currently have none that I know of. I haven't been able to get it into the air for more that a second or two before having to bring it down because of oscillation.

Problem: I had the KK2 board on it and flew it for a while with that until the screen on my KK2 board went bad, so I decided to upgrade it to the arducopter apm 2.6. I have yet to be able to successfully get it into the air. At first I couldn't get it to arm, once I figured that out (was due to the geo fence), now  when i try to fly it it just oscillated extremely fast (unable to fly at all because it oscillates so quickly). I have read through so many of these forums and wiki's and youtube videos, and I just cannot get it to stop. I have tried adjusting every single PID setting and nothing has worked. all my props and everything are still the same from when I flew it with the KK2 board, so I know that isn't it. I have re-calibrated my controller twice now, and the ESC's twice as well. nothing has helped. here are the PID settings that I currently have:

Stabilize Roll:  P: 4.500

Stabilize Pitch: P: 4.500

Stabilize Yaw: P: 4.500

Loiter PID: P: 1.000 

Rate Roll:

P: 0.150

I: 0.100

D: 0.004

IMAX: 100.0

Rate Pitch:

P: 0.150

I: 0.100

D: 100.0

IMAX: 100.0

Rate Yaw:

P: 0.150

I: 0.020

D: 0.020

IMAX: 100.0

Rate Loiter:

P: 1.000

I: 0.500

D: 0.000

IMAX: 100.0

Throttle Accel:

P: 0.500

I: 1.000

D: 0.000

IMAX: 80.0

Throttle Rate:

P: 5.00

Altitude Hold:

P: 1.000

WPNav (cm's):

Speed: 500.000

Radius: 200.000

Speed Up: 250.000

Speed Dn: 150.000

Loiter Speed: 500.000

Ch6 Opt: None Min:0.080  0.100

Ch7 Opt: Do Nothing

Ch8 Opt: Do Nothing

Someone please help me with this, I have been working on this for over a month trying to get it back into the air and its very very frustrating, it messed up the other night and spun out of control towards me and for some reason I put my hand up and ended up with 6 stitches. I really love this hobby and want to stick with it, however I cannot figure this one out. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • ok guys, I have now run into a new problem. when I got back from vacation a few weeks ago I had some trouble with my receiver having an alarm sounding due to telemetry somehow going out of spec which after some research it turned out to be a common issue. I just decided to replace my receiver with a non-telemetry model until I can get this thing in the air. I got it connected and binded it to the tx and plugged in my apm 2.6 to the computer and now I cannot get mission planner to connect. I have restarted my computer, I have uninstalled/reinstalled mission planner, I have rebound my tx/rx, I have replaced the cable that connects to the computer, and I am still getting the same problem.

    I get an error message stating "timeout waiting for autoscan/no mavlink device connected" I am almost fed up with this. Can someone please help me out before I decide to just get rid of it. I am really wanting to start flying this, but am starting to think I should have just bought a phantom seeing as I have spent more on this then I would have a DJI.

  • Often times people experience what you do but never change the PID controller. When I first started out, I had the same issue. Finally I changed the PID controller from 0 to 2 luxioat and like magic the ocilation was gone. To text it out I switched back to zero and it was there again. Some PID setups don't work well on certain PID controllers but are spot on in others. 2 Luxfloat and 3 Multiwii (2.3 latest) work the best in my opinion. Just food for thought.
  • Thanks for the input guy. I leave for vacation in the am so when I get back I will see about adjusting accordingly and post the results. The settings listed here are the pid settings from the original install.
  • Are you sure that your Rate Pitch D: 100 ? this is about ten thousand times its maximum value, if it is copter should oscillate wildly. It is better to have pitch and roll rate values linked (same). Start with P=0.08; I=0.8 and D=0.003

    Look on Internet for PID tuning. Best is to start tuning on the rig (copter suspended on the rope). tune in rate mode (in the rope only) P and D coefficients. After initial tuning you will be able to fly and do fine tuning.

  • Your Rate Pitch D = 100? That should be the reason for the oscillation. Change it to 0.004.

  • Wild guess:

    I once had a severe wobble (then crash) with APM 2.0

    Turned out I had mis-connected the ESC signal cables to the APM.

    If the motors/ESCs are 180 degrees off from correct, you'll flip over violently on take-off.

    But if they're only 90 degrees off, you'll probably get airborne (I did), but with severe wobble (then crash).

    Just make sure - the motors are connected to the APM in the correct orientation.


    • Oh, also (and maybe more likely than outright mis-wiring):

      If your APM is physically oriented in 'X' configuration, but you've chosen '+' in the Mission Planner set-up process (or vice-versa), you'll get severe wobble.

      Confirm correct frame orientation in MP.

      Some people in the past have discovered MP has switched their configuration back to '+' without any apparent input from them (and unknown to them until wobble/crash).


      • Had a similar problem when I was starting up, but in my case I had the speed controls connected to the incorrect PWM output on the PDB. I'd recommend looking into that as well.

  • bump

This reply was deleted.