Let me start off by saying I have been searching the discussion boards for some time now and have now found many if any that are building large Quads using the Pixhawk and the U8 Tiger motors. I am a bit of an overachiever and and wanted build and efficient UAV with long endurance. I have put together one using the following equipment.

1200 mm motor to motor frame.

Pixhawk Flight controller.

Castle Creations 50A ESC's 

6s 15C Lipo Battery

U8 Tiger Motors

28" Tiger Props

Taranis 9XD Radio

Here is my problem. I have gone through all of the calibrations from the flight controler, motors, ESC's and the radio. When I calibrated the ESC's by using the flight controller bypass the motors spin up in reasonable increments as i increase the throttle. When I arm the system the motors begin to spin at an idle speed. When I try to increase the throttle there is no change in response from 0% to about 60%. At that point the motors spin at 100% RPM from 60% to 100% throttle. I have contacted 3D Robotics and the technician told me that he would speak to their engineers and contact me back. I know I am impatient but a week later I still have not answer. I am hoping that someone here can lead me to a solution. I am thinking that there may be some problem with the flight controller.

Thanks in advance

Will

Views: 6805

Reply to This

Replies to This Discussion

Hi Willian, 

Sorry I can't help you. Could you please tell me what frame are you using? 

Thanks 

I am using the V2 PRO QUAD/X8 Frame with 25mm custom Carbon Fiber arms. 

http://www.quadframe.us/ 

A couple of things....First, are you sure you are in Stabilize mode when arming? The way you describe the motors coming up only after the throttle is raised past half sounds like it's in AltHold or Loiter modes.

Second, Castle ESCs can be a bit....different. If you haven't already you would be wise to invest in a USB Castlelink programmer, about $20. You can change all sorts of settings in the ESCs by way of a pretty good GUI interface. Be aware that if you are running the Castle ESCs in their multirotor mode, they have fixed endpoints and won't respond to calibration. You have to adjust your RC Tx endpoints to fit the ESCs.

A way to have a close look at what's going on is to have your copter hooked up to MP while you are powering it up. Specifically look at the Failsafe setting page which shows you the RC in and RC out values in real time. Your RC out should be matching your RC in. If not, then the issue is with the APM. If they do, then it's an issue with the Castle calibration.

William,

what flight mode and which firmware version are you using? 

When arming in AltHold, Loiter, or PosHold (Hybrid) there was no throttle response up to 50%. If you are using 3.2rc4 there is Pre-takeoff throttle feedback. However I strongly suggest to use stabilize mode for take off.

Kind regards,

Thorsten

I see two errors:

1.

I guess your "calibration" was done incorrectly. During calibration the motors shouldn't spin.

"When I calibrated the ESC's by using the flight controller bypass the motors spin up"

2.

6S 15C lipo?

I don't know the amps, but under certain conditions you could be underpowered.

Let's asume you're using a 5A lipo (pls correct me if you use more).

You use the U8 tiger:  (which kv?)

http://flyduino.net/Multikopter-Brushless-Motor-Multicopter-T-Motor_5

There are some with 100kv 25A  up to 170kv 35A

 

Pls. let us know your lipo data and the motors you are using.

I have a hex with Castle 35's.  Could you describe in a little more detail how you went about adjusting the receiver endpoints and any other changes you made to the Castle's please?  When I tried to do an all at once esc calibration, there was no tone at the end to signify success. 

Thanks,

Bernie, if you are using the 35 Amp Multirotor ESCs they have fixed endpoints. The normal all at once calibration will not work with these. To arm them, but not have the motors spin they need to see a PWM signal of less than 1.11 milliseconds (1110 in APM-speak). They output full throttle at a PWM signal of 1.89 milliseconds.

The way I adjusted my RC transmitter endpoints was to hook one of my APMs up to Mission Planner on my PC via USB and bring up one of the real time PWM displays, like the Failsafe screen or the radio calibration screen. That showed me what my current throttle value was. I just adjusted the endpoints in my Futaba transmitter until I was below 1110 at zero throttle and just above 1890 at full throttle. Figuring it out took a while, but doing it took a couple of minutes.

Despite this bit of having to bend to Castle's will, I do love these ESCs. They are small, very light, don't get hot and seem built extremely well. I've abandoned Afros for these as my build choice.

Tom,

Thanks for the reply. i need to check again. My intention was o set the primary flight mode to stabilize. i will check on mission planner when i return home. I have seen that there is some talk of heptic feedback in alt hold and loiter from launch. I am not seeing that in my case, if I made that error. I also have read there are some negative results from some of aircraft flying away.

I have the programmer link for the ESC's. I have not messed around with it much other than to update the firmware. They are set to Airplane mode for now. Is setting the ESC's to multirotor much of a benefit? I am looking for efficiency from my UAV not wild performance.  

I plan to confirm today. I will update when I've done so.

Yeah, there is a distinct advantage to using the Multirotor setting on the Castles, but as I mentioned, also some quirks. The biggest deal would be the ability to do a 490 Hz motor update rate. That's the case in the Multirotor setting, but I'm not sure what you get when you use the Airplane mode (50 Hz??). The 50 Amp Castles default to the Airplane setting, I believe. I'm surprised you need that high an amperage rating at 6S. I would have thought Castle's 35 Amp Multirotor Quadpack would have been plenty. It would have saved you a bit of weight.

That said, I wouldn't encourage you to mess around much with the ESC settings until you resolve what your present problem is. It sure sounds like it was in Loiter to AltHold.

Tom,

Well you saved the day. You know you an look at something a hundred times and miss every time. The default flight mode was set to Alt Hold. I changed it to Sab and it worked like a champ. I took a few short hops today and other than my having huge adrenaline dumps it flew great. i will upload a vid where I i was trying to get the feel of it. I almost had to buy another set of props. Ouch. I saved it at the last minute. I have many loose ends i need to resolve before I consider it solid.  I would like to pick you brain more.

Thanks 

Will

Good to hear it worked out OK. For me, that's a rarity.....

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service