*HELP* APM 2.5+ Not Connecting to Mission Planner

Okay, let's outline what I have; What's happening; What I've done to try and fix it --

What I Have:


I have an H-Quad I just built.  I installed the APM 2.5+ with the uBlox LEA-6H GPS module.  There is no telemetry or other sensors attached at this time.  It's connected to an AR6200 Receiver, and four Hobby King Plush 30 Amp ESC's and then to cheapo HK motors.  I'm using a JR 9303 DSM2 radio. The Battery is a 3S2200 for now (just for testing and motor spin up).  I've downloaded and installed MissionPlanner-1.2.36.msi without issue.  The drivers install fine, and it loads fine.  My primary rig for this set up is a Windows 7 64-bit machine (Intel i7-2600K with 16GB of RAM, and an Nvidia 670 graphics card...for what it's worth).

What's Happening:

Last night I hooked up the APM 2.5+ via USB and was going through the setup of the board.  It downloaded and installed the ArduCopter V2.9.1 Quad firmware successfully.  I then clicked on Connect (after selecting Com11 -- where the APM 2.5+ was configured), and proceeded to the APM Setup (Plane and Quad) section (button at the bottom of the Firmware page).  I went through the Radio Calibration and reversed those channels needing reversing.  All good.  I click on the assignments for the switches, and as I'm going through the options...it disconnects.  Period.  Never to reconnect again.

What I've done to try and fix it:

Okay...something is up.  So...I power everything down...and power everything up.  No good.  Doesn't connect (Mission Planner doesn't list COM 11 nor the Arduino anymore in the pull down menu) and Windows no longer has the "Arduino Mega 2560 (COM11)" listed under the device manager.  I then go through the a re-install of the Mission Planner software and select "Repair" and reboot.  Doesn't fix it.  I force delete the "Unknown" USB device and reboot and reconnect.  Same problem -- Unknown device.  I read on the forums about bad cables...change that. Nope.  

Thinking I have a corrupt install, I uninstall the app. Restore a Registry Backup from before the original Install, reboot, re-install, reboot,and re-connect.  Nope.  Thinking that the drivers may be embedded under the System32 folder, and rather than dig it out manurally....I try another Windows 7 machine. Nope. I try a Windows XP machine. Nope.  I try a Mac with Windows 7 on it via BootCamp. Nope. I try a Windows 7 VM under Linux using VirtualBox. Nope. I try Windows 7 under VM Workstation under both Linux and Windows...Nope.

Okay...So at this point, I try to connect the battery to the APM 2.5+ and then hook up the USB cable.  Bingo!  Now the "Arduino Mega 2560 (COM11)" shows back up under the Device Manager, and is listed under the pull down on the Mission Planner" software. **NOTE TO OTHERS HAVING CONNECTION ISSUES:  Try connecting the battery to the APM before connecting to the PC and see if that fixes it."

Okay, so now that I see the controller, I try to go back in and re-load the Quad firmware...I get an error (see screenshot), but here's a handwritten copy of what it said --

----------------------------------------

Failed to download new firmware: System.IO.IOException: A device attached to the system if not functioning.

at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
at System.IO.Ports.SerialStream.EndWrite(IAsyncResult asyncResult)
at System.IO.Ports.SerialStream.Write(Byte array, Int32 offset, Int32 count, Int32 timeout)
at System.IO.Ports.SerialPort.Write(Byte buffer, Int32 offset, Int32 count)
at ArdupilotMega.Arduino.ArduinoDetect.DetectBoard(String port) in C:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Arduino\ArduinoDetect.cs:line 126
at ArdupilotMega.CGSViews.Firmware.update(software temp) in C:\Users\hog\Documents\Visual Studio 2010\Projects\ArdupilotMega\ArdupilotMega\Arduino\CGSViews\Firmware.cs.line 366

.----------------------------

Okay...this is a problem.

So...I then try to skip the Firmware download and hit <CONNECT>...I get another error (See screen shot)....but it basically says "Access to the port 'COM11' is denied"....blah blah..and points to a bunch of code lines.  Again, see screen shot for more details.

So...now what?  I'm out of ideas, and I'm frustrated.  I'm about to send this thing back for an RMA, as I have enough headache in my life without this thing adding to it.

Thanks in advance for the help!!


Sincerely,

Eric 

Device Manager.PNG

Error.PNG

Connect-Error.PNG

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi tom,

    how have u solved? I'm experiencing same problem with Windows 7 Pro and all my ardupilot boards (VR Brain 5.2, VR micro Brain 5.2 and PX4 clone)

    Tom Evans said:

    Yes !!  Thanks for the followup though ---- I appreciate it :-)

  • I'm having the exact same problem!!  I can successfully upload the 2.9.1. firmware but I cannot connect Mavlink. I've tried all of the "tricks" you listed (i..e. battery first then usb etc.) nothing helps.  I sure wish someone from the dev team would respond on this one.. I'm sitting here with a beautiful 2.5+ APM that's totally useless.

  • Moderator

    If it helps there's a thread here that has a solution to a similar problem but requires replacing a 3.3V regulator.

  • Just for completeness sake, thinking that I may have bad code on my Primary Windows Machine, I attached the APM 2.5+ to another Windows 7 machine after I discovered the necessity of having the battery connected.  The device did show up on the Device Manager, but when trying to connect via the Mission Planner software...I get the *EXACT* same error when trying to push the Quad Firmware to the APM, and it simply times out when hitting <CONNECT>.


    As I think on this, I'm thinking the APM is damaged.  Something caused it to disconnect during the configuration, which may have left the firmware incomplete, and inoperable. I may have to RMA it after all. 


    Thoughts?

    Thanks,

    Eric

This reply was deleted.

Activity

DIY Drones via Twitter
RT @chr1sa: My talk on PX4 and FAA certification is coming up at 1:45 PST today on the PX4 Dev Summit livestream. Includes some cool new st…
Tuesday
DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
Monday
DIY Robocars via Twitter
RT @masato_ka: 距離センサを3つとESP32を付けたラジコンカーをDonkeyCarライクにNNで自動走行。3層FC極小モデルをTensorFlow Lite for microcontrollerで動かしてる。機体は借り物でRumiCarって言います。Tenso…
Jul 5
DIY Robocars via Twitter
RT @SmallpixelCar: My car was able to go all the way autonomously until the crosswalk. It was only 100 yards from the target. What should b…
Jul 4
Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Smart move. The car used the shadow to guide it through the bridge. This was never in the training samples. But it learn…
Jun 30
DIY Robocars via Twitter
RT @SmallpixelCar: Getting closer to the target. Single camera. Untrained road. https://t.co/Wsr7RwDamj
Jun 29
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: #donkeycar https://t.co/czuLoVRcA4
Jun 29
DIY Robocars via Twitter
https://t.co/DKQbNTbz0g
Jun 29
DIY Robocars via Twitter
RT @RoboticMasters: Donkey car, car car car car car car; Donkey car, car car car car car car; Donkey Car. Anyone like our tiny tiny donkey…
Jun 29
DIY Robocars via Twitter
RT @SmallpixelCar: After improving DBSCAN speed, I can get 11 frame per second on @NVIDIAEmbedded Jerson Xavier MAXN mode and the autonomou…
Jun 26
DIY Robocars via Twitter
RT @Heavy02011: Join us at next Virtual Race League: ⁦@diyrobocars⁩ Race #4 - Parking Lot Nerds, August 1st https://t.co/5KUpu7VGaH
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: #CUDA implementation should be easy, because most of the time is on distance calculations berween two points and if the…
Jun 25
DIY Robocars via Twitter
RT @SmallpixelCar: This is the view from the car. Even my lanenet inference is fast on @NVIDIAEmbedded Jerson Xavier, DBSCAN clustering tak…
Jun 25
More…