HELP "Failed to enter command mode" error

I just bought the 3DR 433Mhz radio telemetry kit from DIYDrones..

 

The two boards of the 433Mhz looks same. After I received the kit I soldered the header pins to the boards and connected to the FTDI cable.

 

Now one board connects fine to the configuration tool and I am able to LOAD SETTINGS from it..

and the GREEN LED is blinking..

 

But when I am connecting the other board to the FTDI cable the GREEN LED is solid and RED LED is blinking every 1 second.

Even I am unable to LOAD SETTINGS from the board..
 When I click on the LOAD SETTINGS it shows "Failed to enter command mode"

 

I tried uploading the firmware but it failed..

So I tried in force boot by connecting the GND and CTS and connected the FTDI. The RED LED was solid and then I was able to upload the firmware.

But still after uploading firmware also it has same problem. The GREEN LED is solid and I am unable to connect.

 

 

Here is a video on Youtube to show how it is reacting..

http://youtu.be/qlteJ2ytKiA

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Any updates on what the cause was or how to fix it? Did 3dr replace your radio? I have the same problem with my "Air" Module.

    • So I have been in touch with 3dr and troubleshooted with them, and the result is mine could not be saved. It is unable to communicate with the computer so the firmware has been corrupted. Its a bit annoying as they dont offer a repair service so I have to buy a new unit.

      Good news is the new version 2 modules are compatible with the older version 1 modules.

      • I have tried jumping the CTS and GND together, and was able to force it into boot loader and update the firmware.

        I powered down, removed the jumper and powered up again and I still get the "Failed to enter command mode".

        Sigh. Just another bricked unit I guess. I do wonder how it happened?! So I don't do it again!

        I will have to order another module to replace the bricked one if I want to use 915MHz.

        I have a 433MHz set which is V.2 and working fine.

        • Show printscreen from config tool.

          • Try to inspect board carefuly and eventually resolder - IMHO you have nothing to loose :-)

          • It seems there may be a crack in the board - by squeezing the board between my fingers I can get it to work, and I even forced it into bootloader once! Well the red light stayed solid anyway just like it does in bootloader mode. Might have to rework the solder...?

            But it seems it is definitely NOT BRICKED! :)

          • And now its working again. Weird.

            Will have to try powering up without the ftdi cable but I can see it in Mission Planner now and it has survived several power downs and restarts now.

            Fingers crossed! Thanks again Marcin!

            I think the trick is to force it to bootload, update firmware, power down, remove jumper and then power up again.

            mission planner success.JPG

            https://storage.ning.com/topology/rest/1.0/file/get/3702940587?profile=original
          • I tried to open it in Mission Planner but it had the solid green light of doom and while I can force it to bootload its not happy again. This is so weird!

            It was working! Drat!

          • But now it doesnt work... ? I don't understand - it was working and now its not again?

            It Works!.JPG

          • :-)

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Saturday
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
More…