HELP "Failed to enter command mode" error

I just bought the 3DR 433Mhz radio telemetry kit from DIYDrones..


The two boards of the 433Mhz looks same. After I received the kit I soldered the header pins to the boards and connected to the FTDI cable.


Now one board connects fine to the configuration tool and I am able to LOAD SETTINGS from it..

and the GREEN LED is blinking..


But when I am connecting the other board to the FTDI cable the GREEN LED is solid and RED LED is blinking every 1 second.

Even I am unable to LOAD SETTINGS from the board..
 When I click on the LOAD SETTINGS it shows "Failed to enter command mode"


I tried uploading the firmware but it failed..

So I tried in force boot by connecting the GND and CTS and connected the FTDI. The RED LED was solid and then I was able to upload the firmware.

But still after uploading firmware also it has same problem. The GREEN LED is solid and I am unable to connect.



Here is a video on Youtube to show how it is reacting..

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


          • It Works! Thank You Marcin! Woohoo! Legend!

            First it failed to identify the radio,

            Then it failed to enter comand mode

            So I updated firmware with success

            And when I tried to load settings no joy.

            but after a reboot it stop blinking red and started blinking green and I could see the data in the config tool!

            failed to identify radio.jpg

            Failed to enter command mode.jpg

            Upload firmware success.jpg


            Try to load config and show printscreen.

          • Im Sorry? I used mission planner and jumped CTS and GND to force bootload...

            It succesfully updated the firmware but no joy :/

            Do you know of another config tool other than the ftdi cable?

  • I am joining the club too :(
    Both 433 modules bricked (solid green light)

    any fix?

  • I connected the faulty board to the FTDI cable again today morning, it was same.. Now it is not even going to force bootloader mode also..

    I have mailed this problem to the 3DR team, but they did not reply yet..

  • I tried all the baud rates, still the same..

    Moreover I feel there is some other problem .As the GREEN LED is glowing SOLID and the RED LED is blinking at 1 HZ rate..

    I dont know if there is a problem with the board will 3DR replace the product or not.. :(

  • Try to change the baud rate that you are using in the radio configurator software or in mission planner once you have uploaded the firmware.   Don't assume that it is set up for 57k baud.  I tried every baud rate until I got a match.  Then you can reprogram the radio's baud rate for 57 k and then you should be able to have both radios reply in mission planner.

    Stan Pisarski

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21