Help needed: Servo buzzing

 Hi all, I'm new to the Arducopter and am having an issue which I have been unable to resolve on my own that I am hoping this community can help with. I'm planning to use the APM2.5 to control a custom vehicle which uses Hitec HS-50 servos (relatively small ones, ~6g). All of my testing has been performed on a bench being powered through the APM power cable, and I've also tried powering my servos through an ESC with the JP1 jumper moved appropriately. In each case I believe I am getting a clean 5Vs. I am able to connect to the APM through the mission planner software and also have been successful modifying the code to send custom MAVLINK messages. I have not connected any RC equipment, only the servos, ESC, and telemetry radio.

 The problem I am having occurs when I try to plug in my servos. I know they are not fried because I can control them using the DemoServo script provided, and I've tried different HS-50s as well. When I plug them in, they make a loud buzzing sound, like the servo is being driven at a very high frequency. Applying a little torque to the servo by hand indicates to me that it is being commanded, but again I believe the servo is being burned out by the way in which it is making noise, and know it is not normal behavior. I've tried writing custom commands in loop(), of the form APM_RC.OutputCh(CH_1,1500) to no avail, the buzzing continues.

 Can anyone make a suggestion as to what I should check? Thank you for your help!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I'm not a technical expert on the APM board circuitry, but from my experience of various autopilot and microprocessor-based products, they're not cut out to power servos directly. The main problem is that servo load can change dramatically and hence the current draw on the board will spike at this time. This is a recipe for a burn out, or at best a brown out.

    On my rovers I use an H-bridge based servo/encoder IO board with a separated power rail (5V/3.3V out so I can power a microprocessor board off it). There are plenty of off-the-shelf boards out there; I'm sure you could find one for your purposes.

  • T3
    Where do you have them plugged in? Also did you configured your APM to control your servos? If you did you may have an issue that the APM is not level and it's trying to move the servo to get it leveled. Just guessing? Be warned about how you power your servos. If it comes from APM you might get a brownout on the APM. The APM can't power to much stuff and servos take a lot of APMs.
  • Servos under load will buzz. Digital servos buzz - sometime loud - even under no load. But since HS-50 are analog, I guess they're under some load. Or I miss something.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
DIY Drones via Twitter
First impressions of the Intel OpenBot https://ift.tt/36qkVV4
Nov 10
DIY Robocars via Twitter
Nov 9
DIY Robocars via Twitter
Excellent use of cardboard instead of 3D printing! https://twitter.com/Ingmar_Stapel/status/1324960595318333441
Nov 7
DIY Robocars via Twitter
RT @chr1sa: We've got a record 50 teams competing in this month's @DIYRobocars @donkey_car virtual AI car race. Starting today at 10:00am…
Nov 7
DIY Robocars via Twitter
Nov 6
DIY Robocars via Twitter
RT @a1k0n: Car's view, using a fisheye camera. The ceiling light tracking algorithm gave me some ideas to improve ConeSLAM, and having grou…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: To get ground truth I measured the rug, found the pixel coordinates of its corners, calibrated my phone camera with my standard…
Nov 5
DIY Robocars via Twitter
RT @a1k0n: @DIYRobocars is back in December, but outside. Time to reinvestigate ConeSLAM! I rigged up a quick and dirty ground-truth captur…
Nov 5
More…