How to setup "Current PWM" in flight mode to listen another channel (input)

Hey guys,

After many difficulties, I've been able to connect my Transmitter to my APM.

I would like to setup my flight modes, but the mission planner indicates that my APM is listening on Channel 8 (Current PWM).

For the flight modes my receiver is linked to my apm using the channel 5 or 6 (Aux 1 white wire or Aux 2 orange wire) (see picture below).

So is it possible to change the current pwm parameter to channel 5 or 6?

Or do I need to add an extra wire to connect my receiver to the input 8 ?

Thanks for your help

Arnaud

Views: 3736

Reply to This

Replies to This Discussion

Hi,

You can take any channel on the receiver that you like, and wire that to channel 8 on the APM. It will not control flight mode.

I would suggest that if possible, you also use channel 8 on the radio. Less confusing that way.

What do you mean with "current pwm parameter"?

Regards

Søren

Set FLTMODE_CH to 5 in the full parameter list.

Hi,

I'm using Rover v3.1.0 and want to change the flight mode switch to channel 5 from my transmitter. 

On Mission Planner, I'm looking at; Config/Tuning>Standard Parameters, but there's no FLTMODE_CH parameter. 

How do I change this?  (feel free to be specific).  Thanks in advance

Solved. 

Looking under the config/tuning, I found MNT:MODE_CH and changed it to 5.  Now everyone in my family is happy.

Darren Smith said:

Hi,

I'm using Rover v3.1.0 and want to change the flight mode switch to channel 5 from my transmitter. 

On Mission Planner, I'm looking at; Config/Tuning>Standard Parameters, but there's no FLTMODE_CH parameter. 

How do I change this?  (feel free to be specific).  Thanks in advance

I am using mission planner 1.3.44. There is no MNT: MODE_CH that I can find. Which version are you using @Darren Smith. My current PWM and MODE in the "Flight mode" is always same even if I change the throttle or anything else via the controller.

Hi Amulya! I have the same problem with my APM 2,8 board and Flisky-i6 transmitter. Have you solved the problem?

Amulya Agarwal said:

I am using mission planner 1.3.44. There is no MNT: MODE_CH that I can find. Which version are you using @Darren Smith. My current PWM and MODE in the "Flight mode" is always same even if I change the throttle or anything else via the controller.

Hi Amulya! I have the same problem with my APM 2,8 board and Flisky-i6 transmitter. Have you solved the problem?

Amulya Agarwal said:

I am using mission planner 1.3.44. There is no MNT: MODE_CH that I can find. Which version are you using @Darren Smith. My current PWM and MODE in the "Flight mode" is always same even if I change the throttle or anything else via the controller.

I had a problem with changing of PWM value to set different flight modes. As I toggled my three position switch which is already set to channel 5 nothing was happend. The problem was solved by connecting of receiver (I have FS-iA6) output channel 5 to board (I have APM 2,8) input channel 5. That's it! You can set and change your flight modes or everything You want!

Hello, This is my first time responding to anything here so please excuse any obvious

Mistakes or syntax errors...lol 

I am having a similar problem. I finally got the flight mode to work on Ch5! HOWEVER, now

my channels are showing (according to the Qground station channel monitors) as follows:

CH1 SWC

CH2 ROLL

CH3 PITCH

CH4THROTTLE

CH5 FLIGHT MODE MIX OF SWF AND SWE

CH6 YAW

CH7 no response

CH8 SWB

THIS IS ALL REGARDLESS TO HOW I HAVE THE TRANSMITTER SETUP. IT's  A radiolink

AT10II.Here is the radio settings...1516032958993-841670339.jpg

Someone help please! Thank you SO MUCH...

David S.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service