HOW TO: Windows 8 Mission Planner / Arduino Drivers

Made the upgrade to Window 8 Pro this weekend.  All things considered I have noticed a good speed increase over Windows 7.  No major issues except when I plugged my quad into the USB port Mission Planner couldn't find it. So....

After a bit of digging I found this post: http://arduino.cc/forum/index.php/topic,94651.msg716650.html

in which I found a solution that I thought would be helpful to post here for others.

I'm running Mission Planner 1.2.14

  1. Download the 3 files below
  2. Double-click on the .cert file
  3. Click "Install Certificate"
  4. Select "Local Machine"
  5. Next
  6. Select "Place all certificates in the following store" radio button
  7. Click "Browse"
  8. Select "Trusted Root Certificate Authorities"
  9. Click OK
  10. Finish etc...
  11. Repeat  the process, starting at step 2, replace step 8 with "Trusted Publishers"
  12. Once you've added the .cert to both folders, right click on the arduino.inf file and choose "Install"
  13. Open Mission Planner
  14. Connect.

This worked for me first try.  Thanks to Louis @ Arduino for the great instructions, just thought I could save some folks a bit of time by relaying my direct experience with Mission Planner.

Cheers!

testcert.cer

arduino.cat

arduino.inf

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Just did this on a Asus T100 Transformer!

    Worked like a champ...I had already run the install, and figured out that I needed a fix for win8.

    So after I did these directions, I had to let win8 search for and update drivers on the USB comport wireless dongle I use.

    Works perfect!

    Thanks

    • Just had this problem on 64bit Windows 10 as well.  Fixed it by letting Windows Device Manager search for driver updates... found them, and installed... all working...

  • I work in IT so I'm familiar with how to do things with Windows.  But this one was a pain in the rear.  Finally after 5 tries I have it working in Windows 8.1 on a Surface.  Thanks Andy for the instructions, they work just have to follow letter by letter.

  • Thank you very much for the solution! It also works in MP 2.0

  • Sorry to bring up a years-old thread, but I found this advice here, with these drivers for the Arduino on Win8, via web searches and from a link from the Arduino forums. Someone else might follow those same links and do the things suggested here in this post. I need to warn you all away from this: I just tried this on Win8.1 and though it seems to work at first, the drivers provided here are actually unstable and will eventually cause the system to BSOD (Blue Screen Of Death). The quickest way to get the computer to BSOD with these drivers is to suspend/resume the system. I've experienced this BSOD with two different laptops now. To fix this BSOD problem: Uninstall these drivers, delete them completely, then go back to the "Old" method of disabling the unsigned-driver-check and using the official Arduino drivers, as described here: http://forum.arduino.cc/index.php/topic,94651.msg727588.html#msg727588

  • Hi Andy. I followed your instructions and got Arduino working on my Win8 computer. Thanks for posting that info. However, I consistently receive an error when trying to install the Mission Planner. I made sure that I have the .NET 3.5 framework and DirectX as mentioned in the install directions but that didn't fix the problem.

    Did you run into similar issues when you put Mission Planner on your Win8 computer? If so, is there a quick fix to the issue? Thanks for your time and consideration.

    Garret

  • Almost no effect on my day-to-day and I run a software company so lots of Office usage, Netbeans, local dev webserver and no issues.  I just ignore the new homescreen for now it's not really an issue.  It probably helps if you're used to launching apps by hitting the Windows Key, typing and hitting enter (similar to Mac Spotlight).  Everything loads and runs faster compared to Windows 7 in my opinion.

  • How do you find Win8?  Looks a bit tablety and mobile phoney, rather than desktop PC?

  • Thank you very much for the solution! Didn't even know win8 was out already. I don't feel like upgrading from win7_64 everything works so good. Perhaps the nonworking missionplanner on win8 was a feature not an incompatibility :) .

    So long

    Rob

This reply was deleted.

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…