I have been using my APM1 board for a while now with APM Planner as an ArduCopter 2 mode and am now trying to get it to work as ArduPlane.

I have downloaded the firmware with in APM Planner (1.1.77 mav 0.9) with Firmware->ArduPlane 2.33.

Seems to download ok. 

I connect using USB in ArduPlane mode, everything seems ok except the HUD will not respond when I move the board about.

If I go to the CLI and type test->compass the readings the values displayed look good and respond.

If I switch back to ArduCopter2 firmware the HUD it works fine.

Any ideas?

Views: 653

Reply to This

Replies to This Discussion

im confused. so when does it work, and when does it not work

A. With Arducopter firmware:
HUD orientation works fine. Responds to movement.
B. With Arduplane firmware:
1. CLI can tall to compass so I am assuming sensores still work in ArduPlane.
2. HUD does NOT respond to movement.
3. HUD still updates time.

Also, when it starts up, the mode on the HUD will just say "Initializing.." indefinitely until I manually change the mode.

Still don't know if it's a APM Planner issue or APM1/ArduPlane issue.


you do have a gps plugged in? and it is getting lock?

This is inside a house so no GPS lock. I've tried it with and without GPS connected, no difference.

Does it need GPS lock for gyro/compass orientation?

it needs gps lock to leave initilizing.

Thanks. It must be some other hardware problem that is only happening on ArduPlane. I've checked. I've checked the GPS in CLI test mode and it is ok. Must be some some other problem while initialising. So it seems not to the an APM Planner issue.

Thanks for the help though.

I am facing the same problem

- No HUD indication on MissionPlanner-1.1.87 with APM1 + ArduPlane-2.34

- HUD indication OK with  MissionPlanner-1.1.87 with APM1 + ArduCopter-2.5.4


Any solutions?


Hi Peter !!! Problem Solved !!! Your suggestion was of great help !!! I can now proceed with my plans !!! I do not have Xbee or an OSD. As you suggested I flipped the switch to "fly" position (away from the edge, toward the GPS connector). I connected APM1 hardware to APM Planner the HUD indicates motion as I move the hardware !!! Thanks again !!! Mahesh M.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service