I'm having some trouble- perhaps I'm doing something wrong?

I'm trying to control a camera gimbal I made with RC channels 6 and 7 out, using a USB joystick.  I'm having some trouble with the joystick configuration. I got one axis to work by mapping the joystick X axis to channel 6, then changing RC_6_Function to 1.  That servo moves fine.  After that, the software won't let me map any more joystick axes, on any channel. 

Views: 2801

Reply to This

Replies to This Discussion

I'm kinda curious about this too.  I'd like to use the joystick hat switch to control a camera gimbal.

make sure you calibrate the joystick in windows first.

It seems that the joystick mapping to all flight controls works very well, however things start to get strange when the joystick is mapped to the auxiliary inputs.  The mapping appears to work until a connection with the board is established, and then it seems as if no values are being read from the joystick.

Michael, I'm still having trouble with this. I want to map joystick X&Y to RC_6&7. I tried calibrating in windows, but I just can't get the joystick to map to these channels. Thoughts? 

I'm interested in doing this myself but I'm aways off on even attempting.  I'll follow this thread, good luck guys.

Hello everyone ... Has anyone made any headway on this  - using the game pad to control aux outputs? I seem to have the same issue ... calibration works fine until connection to the board as mentioned above... then nothing happens and the inputs from the game pad seem to not be recognised.

Are you talking about channels 5,6,7 on the output side? Here is what I was seeing


- I mapped the gamepad thumbstick on the left to channels 5 and 6 so I could use it to control an FPV camera. This worked fine in the GCS when setting up and I could see input from the thumbsticks moving the progress bars on screen

- I connected to my plane using XBee

- Moving the joystick had no impact on the camera servo's - it was as if the input was being ignored. The progress bars on the GCS screen showed nothing.


After a bit of playing around, the following fixed my problem.

- Go to the Basic Parameters screen in the GCS and set channel 5 and 6 (or whatever you are using) to function as "manual"

- Go to the All PIDs (I think - I don't have the GCS on this computer & can't remember the exact name of the option) screen in the GCS and set the min and max PWM range for channel 5 and 6 to something other than 1500 and 1500. If these channels were not set up as part of your radio gear set up (as mine weren't) they will just default to these values. The flight channels will have been configured which is why they work.

The last step was the critical one to get things working.


Hope that helps




Thanx James .. that makes perfect sense ... I will try this as soon as I'm back at the workshop.

Will feed back later..



I tried this and it works!! :-)

Have you had any luck using the hat switch?

What about using the "hat switch" to control the gimbal? I have a normal joystick with a hat switch at the top which i hope to be able to use to control the camera. Has anyone been able to do this?

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service